No Movies in Media - metaData.sapphireDataV3 missing

Just bought and installed aTV Flash yesterday. I did all the updates, installation routines, etc.
I only want to use a external HDD for my DVD Collection.

After import of 4 DVDs (for testing) on the external HDD the Movies are not shown in the MEDIA menue.
Now I found the Console Log. There I can read very often something like that:

Finder(326( Save error “NSError " An error occurred while saving.”
Domain=NSCocoaErrorDomaine Code=134030 UserInfo=(
NSAffectedStoresErrorKey = (<NSSQLCore: 0xdd440d0>);
NSFilePath = “/Users/frontrow/Library/Application Support/Sapphire/metaData.sapphireDataV3”;
NSUnderlyingError = NSError “File does not exist.” Domain =NScocoaErrorDomain Code=4 UserInfo=(
NSUnderlyingError = NSError “POSIX error: No such file or firectory” Domain=NSPOSIXErrorDomain Code=2 UserInfo=(
NSfilePath="/users/frontrow/Library/Application Support/Sapphire/metaData.sapphireDataV3":wink:

With Cyberduck I realy can’t see metaData-File in above mentioned folder.
At http://forum.atvflash.com/viewtopic.php?f=6&t=3326&start=0 aTV Flash wrote following, but that doen’t work at all:

Postby aTV Flash » Tue Jul 13, 2010 7:55 am
It looks like there is an issue related to share points that is causing problems for some users. This can easily be solved by removing the ‘mounts.plist’ file from the AppleTV.

  1. Connect to the AppleTV via FTP (http://wiki.atvflash.com/index.php?title=FTP)
  2. Navigate to the Library/Application Support/nito folder.
  3. Remove the ‘mounts.plist’ file.
  4. Restart the AppleTV.

We’re working to find out why this file is causing an issue but the steps above should get you back on track for now.

Best regards from Switzerland, waiting for solutions…

Hi Daniel,

I have exactly the same issue, namely metaData.sapphireDataV3 file is missing after upgrade of Nito and Sapphire. As a result can only “see” movies and tv shows through Collections, and am constantly reprompted for metaData and cover art each time I “Import All MetaData”. Note that I have no mount.plist file in the Nito folder either - suggests that not problem not related.

Regards
K-Man

Please let me know, also when you don’t have an idea to solve the problem yet.
I’m not very satisfied and the day’s of my “Satisfaction Guarantee” are counting backwards…

You may try removing the Sapphire database and starting over.

  1. Update Sapphire through Maintenance --> Manage Plugins menu (a new version was released a day or two ago).
  2. Connect via FTP (http://wiki.atvflash.com/index.php?title=FTP) and remove the ‘metaData.sapphireDataV3’ which is located in the Library/Application Support/Sapphire folder.

Hi guardianmax,

Tried your suggestion - got latest update, followed your instructions - symptoms still the same, no change, metaData.sapphireDataV3 still missing.

Regards
K-Man

Hmm ok. You may try clearing the entire contents of the Sapphire folder (located in Library/Application Support/) to see if that resolves your issue.

1.) I updated Sapphire, restarted aTV, still no ‘metaData.sapphireDataV3’. Still movie-data is NOT saved, so imported movies do not show up in menu.
2.) I deleted all files and folders in “Library/Application Support/Sapphire”, restarted aTV, still no ‘metaData.sapphireDataV3’.
3.) Imported all new content (in German Menu “Alle Daten importieren”) from external HDD. After choosing the cover-pics, I can find now the folder /Collection Art/@MOVIES with 5 jpg-files in it, but still NO movie-data saved. If I go directly after importing new media to ‘movies’, I can see only a few of the imported movies, with duration, Oscar symbol, etc… But only for some seconds. After going back to menu and again to ‘movies’ everything is gone. :frowning:
4.) Still not working. What to do now? Next try… Waiting for instructions.

Hi Daniel & guardianmax,

I have exactly the same symptoms after following exactly the same steps (except using English)…

Regards K-Man

Are you seeing a black screen or are you having issues with Sapphire. If a black screen you may try the steps here: http://forum.atvflash.com/viewtopic.php?f=6&t=3326#p13978

Hi Max,

Not black screen. Issue is with Sapphire, does not “store” metadata, as detailed by Daniel.

Regards
K-Man

This file may not be automatically creating itself if not already present. You may try downloading the blank file in the link below and copying it to the [i]Library/Application Support/Sapphire[/i] folder via FTP (or [i]/Users/frontrow/Library/Application Support/Sapphire[/i] when connected via SFTP) to see if this resolves your issue.

[i]A guide for connecting via FTP can be seen here: http://support.firecore.com/entries/259290-transferring-files-via-ftp[/i]

http://dl.dropbox.com/u/111543/Dev/metaData.sapphireDataV3

We'll try and replicate the issue here.

Hi max,

Success at last. Firstly I copied the file you provided and placed in Sapphire Application support folder. Initially this had no effect, however, I then uninstalled Sapphire through the Maintenance—>Plug-ins Menu, and re-installed, then re-imported All Data - and lo and behold, Sapphire sorted all files into correct Movies and TV Shows folder, displays cover art, and all information correctly. Have restarted Finder four times, and now seems stable. Thank you for your assistance.

Daniel suggest you do the same, and you should have same result.

Regards
K-Man

Copying the file solved my problem, too.
Thank you for that great service.
I saw today, that you sent my money back because of the “Satisfaction Guarantee”.
After my problem is solved, I’ll have a second look an ATVFlash.
If I’m satisfied, I’ll buy it again, I promise…

I just tried this and it did not work for the missing TV Show which is only displayed under “Collections” and not “TV Shows”. Having said that, perhaps a warning that this process with delete all your current MetaData and require you to make choices for each file, would be appropriate. A proper fix would be even more appropriate.

I have the same problem with Sapphire, current version: metadata is loaded, but Sapphire seems to forget it once I navigate away from the application.

One difference in my situation is that I didn’t find the Sapphire application support directory (or any other Sapphire directory) mentioned in a post above. I created that directory to match the given path, and added the empty metaData file, with no change in behavior. (I then uninstalled and reinstalled Sapphire without any effect.)

Any help? I bought ATVFlash primarily to added the external drive support, to enable FTP access, and to be able to play DVDs on the AppleTV without having to go through Handbrake first. I’m currently 1 for 3, and haven’t tried the external drive support yet.

UPDATE: as per the other current Sapphire thread, I’ve tried updating the scrapers and restarting. Still no change.

Thanks for any pointers.
Ivan

RESOLUTION: the problem was that I placed the empty metaData file in the wrong directory. I read the original location “/Library/Application Support/Sapphire” as being off the root of the drive. The correct directory from root is “/Users/frontrow/Library/Application Support/Sapphire”. Running “touch metaData.sapphireDataV3” in that directory and then restarting solved the issue.

Sorry about that. I’ve updated the original post to clarify this.

I had the same problem and followed your solution. I ran into an issue after reinstalling. I have about 200 movies on my external drive, so when the importer started the import (and was going to ask for each movie confirmation and poster choice) I cancelled the processed and changed to automatically select. I then restatrted the import, but it hung up. I believe this action somehow damaged the database, and then no movies showed up. I then uninstalled again, reinstalled and placed the blank file in the folder. I then manually selected the movies and tv shows. That worked, but it took like an hour to select the correct movie, then the correct poster.! I have since added a couple of movies, but it is now stable. I suspect the new version is having trouble keeping the database stable. It is certainly less reliable than it was 6 months ago.

 Ok tried this - I have  replaced my metaData.sapphireDataV3 4.8mgb file with your zero byte file.

Still no joy. I am still watching the Apple Logo - seems to refresh itself every 20 seconds but never loads frontrow.

 Thank you, max. That worked.

 Same problema here :-(

Any news???