No more streaming from iMac? why?

First of alll sorry for my english, I’m italian…
Infuse Pro (latest version) it’s the one and only app that I use on my apple tv, streaming videos stored on my iMac m1 with SMB protocol and shared folders.

Since a few weeks, everything become unresponsive and now I cannot stream nothing more. I can see and add folders in infuse, sometimes with metadata etc…but when I tap play nothing happens, spinning wheel forever. Of course I tried to restart computer, apple tv, reinstall apps, delete data, turn on and off shared folders and data on iMac, check router, apple tv…nothing! I think it’s an Infuse Pro bug maybe, don’t know what do to anymore…please help!

p.s. same story also when I try to stream from iPhone app


There are a few things to check.

  1. SMB is enabled on your Mac (more info here Set up file sharing on Mac - Apple Support)
  2. At least one user is selected under ‘Windows File Sharing’ (as shown under ‘Advanced Options’ in the link above)
  3. The folders/drives you wish to share are added to the list of Shared Folders
  4. Selected username and password are being entered in Infuse

Note: iCloud username/password cannot be used. If you’re using an iCloud ID to log in to your Mac, you will need to set up a new ‘Sharing Only’ user as described here: Change Users & Groups settings on Mac - Apple Support

Also, if you’ve recently installed an update for macOS, you may need to disable and then re-enable File Sharing to get it working again. You can also try one of the tips found here. Ventura SMB Connection Issues

This also may be related to an Apple bug as there are others reporting the issue here.

There are some suggestions posted in that thread, and they basically entail.

  • Turning off/on File Sharing
  • Disabling the Firewall in macOS settings
  • Disabling all VPNs
1 Like

thanks a lot for all your info, but I tried everything multiple times, it’s still stucked on spinnin wheel when I tap play…I can see folders and data, movie info and etc…browse folders, but it’s not working anymore when I start to play :frowning:

what else could be? a bug with iMac m1 processor after some recent updates? it’s not working both streaming on apple tv than iPhone 13 pro max, I think it’s something happening on iMac

I spent ages trying to sort a similar issue. My Nord VPN was interfering. I switched to NordLynx protocol and the problem disappeared.


thanks, sadly there is no VPN in my network :frowning:

Are you able to watch the videos on your AppleTV using any other app (such as VLC)?

Did you try anything other than SMB?

Great question! I tried with vlc on Apple TV and it’s fast and working as hell! So it’s an Infuse issue 100%, not a network problem…

What can I do?

I’m not a Mac guy, but

My video files are on iMac, what else should I set instead of SMB? Thanks

I don’t use a Mac, so I can’t tell you for sure which other options are available to you (perhaps other Mac users can chime in); but Infuse supports so many, there’s probably something.

so it’s 100% confirmed that it’s an issue related only to Infuse, both on iphone and apple tv app. I can stream flawless with VLC app and my SMB sharing from iMac m1 is working correctly.

What else could I try? Please Infuse team, help me or, sadly, I will cancel my longtime subscription :frowning:

If you’re able to send in a report from Infuse and post the 5 digit code here, we can look deeper into this.

here they are:
“JQ4PT” from iphone app and “ANKST” from Apple TV 4K (A2169 model) tvOS 16.5

I still confirm that everything it’s working 100% correctly and super fast streaming from my iMac M1 to VLC app on apple tv and SMB sharing, but infuse app continue to NOT work anymore, like always before :frowning:

another strange thing I’m noticing is that the INFUSE app also has difficulty downloading the cover-movie data from your servers, I wouldn’t want my problems not to be related to the network but rather to a slowness that the app has in contacting the servers and getting answers on everything needed to make the interface work. Even when I want to edit the cover of a film, before it was very fast, while I was writing I already had the alternative results of other covers, now it’s very slow even in doing this trivial operation. Ideas? help? Thank you!

Brief aside for the record … Firecore doesn’t have servers.

Firecore’s Infuse software versions are hosted by Apple, on Apple’s various App Stores.

Their apps gather metadata from TMDB’s servers or their customers’ own media management servers. All users’ content is provided by the users. Users’ watched statuses may be synced with Trakt’s servers or Apple’s iCloud (which also may be used by customers to backup other collection metadata). Nothing required by or utilized by Infuse is hosted or provided by Firecore.