No light on 2nd jailbreak.

I recently jailbreak my atv2 5.0 on the new seas0npass and it worked fine. 

 

now that i want to jailbreak another atv2 5.0, there is no light once i plug in the micro-usb. 

I’m guessing i need to reset my seas0npass so it can read a new atv but i don’t know how to do it. 

can you please tell me why there is no power once i plug in the micro-usb because it works with the other atv. 

 

thank you in advance.

Try plugging your Apple TV with the power cord for about 5 seconds and then it should work. 

Some Apple TVs come with no power at all in the batteries and require a small charge before you plug it into your computer.

are you sure it is atv2?

Im positive its an Apple tv 2. I just tried plugging it in a power source for 30min to charge a battery and then plugged the micro-usb and still no luck.

any other solutions??

connect usb to pc then power cable it should pick up restore mode.

Still no luck. I connected the power source along with the micro-usb and i restored it in iTunes. I then disconnected the power source and then the apple tv just dies on me. 

 

maybe there is something wrong with my computer?

Connect the micro-usb, then connect the power cord.   Now with the light blinking, hold down the menu and play button on the remote for 7 seconds while facing the apple tv.    Then unplug the power cable and the light should stay on.

still no luck:(

how about just keep the power cord connected the whole time i did like that for my first jailbreak on 5.1 and i didn’t get a problem

I’M SO SORRY GUYS! I JUST REALIZED I BOUGHT A ATV3. I NEVER KNEW IT WAS OUT IN BELGUIM.

I think its difficult to find atv2’s, so I’m going to keep looking around stores and in the meantime I hope they find a jailbreak for ATV3. 

again, I’m so sorry for the inconvenience.