No library

Hi Everyone,

I have just bought the lifetime license of Infuse. I have used Infuse 5 pro for some time before.

It seems that I don’t have a library at all. My favorite is on smb server, and I only have a few movies in the Favorite folder. However, if I go to “Setting - Library”, I don’t see the Favorite folder available to be checked for Library adding.

I’m using Apple TV 4K.


Welcome to the forum!

First do you have a check mark next to “Show Library”?

HI Thanks.

As I have said, I can’t see any favorite under “Settings > Library”, so there is no possibility to place a checkmark next to any favorites want the Library to index.

Any suggestion?

I’m not talking about the check marks next to the favorites, there is an option to turn the Library itself on and off by clicking on the “Show Library” and that will place a check mark on the right hand side of that label.

Can you provide a screen capture of your “Library” settings screen?

Hi, I have replied the email to respond. Seemed it’s not working.

Please see the screenshot.

I have one favorite folder which is accessible from Infuse. As I am new user, I can’t upload more screenshot.

Just to make sure we’re not having a semantics issue, when you go to Settings > Shares > and then click on your “Saved Share” The next screen should list your favorites and give you the option to add more favorites.

Do you have any favorites on this screen? If not could you try and add one?

Do you have anything between the word on top “FAVORITES” and the “+ Add Favorite (s)” ?

This is from the users guide here


The short answer to your question is yes and yes :slight_smile:

See the attached.

I am not the new user of Infuse, I have used Infuse 5 pro.

How are you connecting to your device?

Are you using UPnP or DLNA by chance? Unfortunately, these options won’t be compatible with Infuse’s library features.

I was going by your first post

but as James said, Infuse Library doesn’t play well with DLNA so check on the edit share screen and double check the protocol to make sure you didn’t accidentally select the DLNA share from your server instead of the SMB share.

Thanks @NC_Bullseye and @james , I decide to give up :grinning: I think my old NAS is hopeless, I am going to replace with a new Synology NAS, so hopefully everything should be working.


Good luck!

@NC_Bullseye & @james
hey guys, i almost have the same problem, i’m using a apple time capsule
could you check my problem with this id: #141107

Welcome to the forum!

Some background info would help. What version number of Infuse and what tvOS number are you using? Also when you send in a diagnostics report Infuse will give you a 5 digit alphanumeric code you can post in the thread that will help the devs find things.

Have you gone through the users guide with tips for connecting to a Time Capsule here?

thanks for quick res.
i’m using infuse pro 7.3.1 (3956) and my tvOS is : 15.2 (19k53)
the code for diagnostics report is : 96ACP
it’ll be great if you could help me, this feature used to work like a charm before, i don’t know what wrong with my configuration
by the way, i’ve setup my TimeCapsule as SMB

i’ll go throw the topic you said as well and check if it can solve the problem or not

Dear my problem didn’t seem to get solved, i have just experienced one think that might help with the case
i just installed infuse 4 again in my apple tv and it worked! (attached pic)
but infuse 7 doesn’t gather the data in library.
very confusing!!!

Can you post a screenshot of the Settings > Library page you see in Infuse 7?

I’ll send photos of all my screens, including share and library and …

could you find anything regarding my problem with library in infuse 7 for tvOS?

Can you try using the Clear All Metadata option in Settings, and let Infuse scan everything again?