No deinterlace option for VC-1 29.97i video streams

Hi.

I have noticed that older Blu-rays that use the VC-1 codec, there is no deinterlace option in Infuse.
My issue is that I have remux MKV’s of a tv show where some seasons were encoded as 29,97 interlaced (telecined) instead of 23,976 progressive which results in duplicate frames and judder.

Here’s the MediaInfo for the file:

Video
ID                          : 1
Format                      : VC-1
Format profile              : Advanced@L3
Codec ID                    : V_MS/VFW/FOURCC / WVC1
Codec ID/Hint               : Microsoft
Duration                    : 22 min 55 s
Bit rate                    : 16.0 Mb/s
Width                       : 1 920 pixels
Height                      : 1 080 pixels
Display aspect ratio        : 16:9
Frame rate mode             : Constant
Frame rate                  : 29.970 (30000/1001) FPS
Color space                 : YUV
Chroma subsampling          : 4:2:0
Bit depth                   : 8 bits
Scan type                   : Interlaced
Scan order                  : Top Field First
Compression mode            : Lossy
Bits/(Pixel*Frame)          : 0.258
Stream size                 : 2.56 GiB (94%)
Default                     : Yes
Forced                      : No

I’m using an Apple TV 4K 2021 using the latest tvOS 15.5.1 as well as the latest Infuse 7 Pro version.
For AVC encoded interlaced content, the deinterlacing options appear - making it possible to apply IVTC. But for some reasons, VC-1 interlaced videos will not show the option at all.