No cover art - iOS and ATV2

I saw a post from yesterday indicating cover art was not loading successfully. I am also having this problem, both on iOS and two different Apple TV 2s.  It appears to be a problem after a specific point in time, since one movie that was indexed earlier on iOS has cover art, but the same movie on both ATV2 cannot retreive the art.

Did change their API?

Any insights?

I've been experiencing the same problem. Started noticing the issue earlier this week.

I'll also add that all other metadata seems to be retreived correctly... it's just the cover art that is a problem.

I can confirm that the problem seems to be limited to cover art retrieved from  I just added a TV show, and the art came in fine for both ATV and iOS clients... this indicates (to me) that is retrieving art fine, while is not.

I found the procedure for reporting bugs on ATV (, but not for iOS.  Anyone know the procedure?

This is related to a recent change at TMDb.

We've worked with them to get a workaround in place that allows the current version to work as expected.

A new update of Infuse (2.3.1) was just submitted to the App Store which includes a permanent fix. An Apple TV version will be available soon as well.

Thanks for your patience.

Tremendous.  Thank you for the prompt support.

While waiting for the new Infuse to show up in the Apple store, I added a new movie, and the cover art did appear (presumably thanks to the temporary fix worked out with  However, movies that were already indexed without art still do not get art, even when I edit/refresh the metadata.

Any ideas on how to remove a movie from the library, and then add-it back?  Or any other workaround that might permit me to get the artwork for the movies that previously did not index properly?  (Beside nuking all metadata - which is an extreme and laborious workaround...)


The new update was just approved by Apple, and should be rolling out to the App Store as I type this.

If you have movies with the correct text, but no artwork you may try this.

  1. Update to the latest version that was just released.
  2. Try using the edit option to reload the metadata for the affected movies (
  3. If that doesn't work, try selecting a different title, then repeating the process to select the correct one.

Updated Infuse on iOS last night, refreshed the metadata, and all is well now.

Again, thanks for the prompt support!