No computer will detect my ATV2 no matter what.

Greetings all, any help you could provide would be much appreciated as I am beyond frustrated with my ATV2 2nd Gen.  I bought this thing about 6-9 months ago and Jailbroke it immediately; I believe the latest version of the OS at the time was 4.3 or something.  I started having trouble with XBMC recently after trying to install a skin, and it was randomly crashing on me, so I decided to refresh everything by updating to the latest Jailbroken firmware.

I downloaded seas0npass and started the process, only to discover that no matter what I do I cannot make it past the DFU mode part.  I’ve tried on a early-2011 Macbook Pro, a Windows 7 Desktop that I recently built, and an older Sony VAIO also running Windows 7.  I’ve tried every combination of resetting the ATV2, using the power cord / not using it, Menu+Down, Menu+Pause/Play … I’ve watched countless youtube videos and tried every method I can find suggested, and nothing seems to work.

I’m trying to figure out the root of the problem; I don’t think the ATV2 is being detected by the computers period.  I don’t see the device listed under iTunes on any of the 3 computers, and I can’t figure out how to tell if the computers are actually detecting the thing or not.  They are all running the latest version of iTunes, and all behave the same way.  I remember originally being able to see the ATV2 in iTunes when I first got it, but it’s simply not working now.  Not only that, but iTunes has ZERO options for the Apple TV in the Preferences.

So anyone have any suggestions?  I don’t understand how it can just be not working after it has worked fine for all this time.  I really don’t know what I’m doing wrong, and I’m ready to throw this thing in the trash.

Thanks for any help you can provide!

OK first thing first - change USB cable.

I’ve tried 2, but they both came from a set of Samsung 3D glasses … they are used to charge the glasses while plugged into a Samsung TV’s USB ports.  Is it really possible that both cables are either bad, or incompatible?  They don’t appear to be any different than a normal Micro USB Cable; if that’s the case I’ll have to literally go to a store and buy one.

With the Apple TV connected run this program (Windows only): Please screenshot the item in the tree view that is the Apple TV (assuming Windows detects it).

Are you connecting it to a USB hub, monitor ports or front ports on the PC (sad but should be the back).

When you connect the USB and Power try the following (although you already did)

  1. Menu + Down until the light flashes really quickly

  2. Menu + Play/Pause until the light flashes steadily

  3. Check USBVIEW again and the Apple TV device should say DFU Mode (can also say iBoot or Recovery Mode both of these are not the state you want to be in when trying to flash the device).

It is quite possible these are ‘charging only’ cables and do not have the data lines connected. You need a cable that supports both charging and data.

You were right, the cable was the issue.  I just went and bought a new one and it worked fine.  Now if I can just get XBMC to launch without crashing I’ll be golden.  Thanks!