No ATMOS from Apple TV 4K - Connected to Samsung HW-N850 Soundbar

Ill make this new thread, my old problem is now solved thanks to some help here and some luck I guess :slight_smile:

New Problem is that I do not get ATMOS setting available in the Apple TV settings.

My setup

  1. Samsung TV (model 2016) 75KS8005 → HDMI Arc → Samsung HW-N850 Soundbar. (This was with the HDMI-cable provided with the soundbar)
    I have changed soundformat on TV to Bitstream and Dolby Vision
    I have enabled UHD Enhanced Color Depth on the HDMI port (or whatever the name was :p)

  2. Apple TV 4k → HDMI → Soundbar
    Settings is viewed like this, https://i.imgur.com/oDRPWoZ.jpg. (And I can only choose Dolby Digital 5.1 or stereo here when auto is not picked)

  3. PC → HDMI → Soundbar
    When playing Dolby Atmos things from the Windows 10 app (Dolby Atmos) the soundbar shows “Dolby Atmos” So it does work here.

Any ideas why its not working from the Apple TV? Could it maybe be the HDMI-cable that is not sufficient? I did read on an apple site that you do need a HDMI cable that has this text on it “Compatible Dolby Vision”. Is that correct?

Hmm so the Apple TV is connected direct to an ATMOS sound bar, well you should receive Atmos that way automatically. I didn’t have to do anything. I have a 2meter premium certified hdmi cable from Amazon that only cost me £15. Seeing that your PC picks it up doesn’t make sense why the Apple TV wouldn’t.

Maybe check the n950/850 AVforums about other users with this soundbar and Apple TV

Try restarting your Apple TV or unplug from mains.

Maybe insert hdmi into the one the PC is in to see if that works?
The last thing I would do is a factory restart of your Apple TV

Here what it should look like below. I’m not sure how else I can help to be honest, your setup looks correct.

2 Likes

Okey I got everything working with ATMOS now. Then of course there is a new problem for me…

I bought the rear speakers SW9000. Have connected them and the blue light is solid. I have changed rear level to 6. I have not put the wires in to long in the speakers. But I can barely hear them. Just some strange background noise? Ive tried playing movies, spotify and I have changed from standard, smart and surround but no difference.

Any tips here??

1 Like

I have the same problem, please tell me something!

You need to be a bit more specific, do you have the same sound bar and rear speakers but can’t get them working? With what app? iTunes, Netflix, or Vudu?

I have everytthing sorted out now. I did think that I should raise all speakers to 6 or keep them at high numbers for more sound. But they should go at 0, then I just changed the rear to higher and it works like a charm for me. Have also fine tuned some bass to it, and the virtual is set to off for me

Apple 4K Samsung 850 sound bar lg OLED I Hooked apple to sound bar aseperate hdmi to tv non arc. You don’t need arc since no sound is going to tv all other components are hooked to sound bar. Dolby Atmos works great no lipsyn issues. I gave up Dolby vision for hdr but I’ll take the atmos

Just FYI, “ARC” doesn’t handle sound going to the TV, it sends the sound from the TV to the amplifier.

Just FYI, “ARC” doesn’t handle sound going to the TV, it sends the sound from the TV to the amplifier.

Sure? AFAIK, ARC works bidirectionally. If you connect a DVD/BlueRay player, AppleTV, etc to a receiver or soundbar HDMI IN, then you connect their HDMI OUT to the TV via the HDMI (ARC). The audio is handled by the receiver or soundbar and the video signal is sent to the TV. If/when the receiver or soundbar is off, also the audio is sent to (or handled by?) the TV. Conversely, when you watch TV with its tuner, the audio is sent trough the HDMI (ARC) to the receiver or soundbar. Maybe I’m wrong but this is what I deduced from different sources.

The way it was explained to me was that HDMI standard handles the audio going to the TV and ARC was the additional factor that allowed the TV to send audio to the AMP/Sound bar via the HDMI cable instead of having to have an additional optical cable or other for audio. I’m sure there are other features and specs involved but this was just a simplified response.

I use “Tom’s Guide” often for a quick check of all the goodies since I don’t work in the AV field except for my own needs. It’s usually pretty right on the mark. Not saying I don’t misinterpret things at times and over simplify things other times. :wink: https://www.tomsguide.com/us/hdmi-arc-faq,news-26262.html

Yes, this is the primary intended use of HDMI ARC, but I think it was important to comment that being a two-way interface it can also send audio to the TV. Tom’s Guide is a good source and explains all this quite well.

i’ve got my 4tv connected to my hw-n850 to hdmi 1 on the sound bar my samsung q55 is connected to the soundbar via arc all bought films from iTunes play in atmos on the soundbar, netflix on 4tv play in atmos. anything in true hd atmos, played via the synology NAS do not show up as atmos as the metadata is not sent. this is a know issue that will hopefully be fixed

This needs to be implemented by Apple. MrMC beta is working on a way for DD+ atmos to work in MKV containers however only webrips seem to be in this format.

Not just beta, they already released it. The beta is for certain files that weren’t working after the release.

Just checked the mrmc website and yep says Atmos passthrough supported. Gonna check it out tonight hopefully this is coming to infuse 6

from MrMC forum site:

MrMC supports eac3/atmos on the appletv4k.

truehd/atmos is not supported.

correct atmos truehd does not work :frowning:

Please explain. Are you running an HDMI splitter from the ATV to enable to HDMI cables to run from the ATV, one to the K850 and the other to the LG Oled (not through ARC)?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.