NitoTV Weather Removal

OK, I made the mistake of installing NitoTV MainMenuWeather. How do I remove it?


I now only see "Error, Please Check the Selected Location" message at the top of the main screen, but see no way to remove this from within NitoTV, nor where I select the location. Is there a remvoe method out there for MainMenuWeather I am not seeing?

Removing NitoTV does not remove this feature.

Nito installs a "custom settings" menu where you can enable/disable plugins like the weather etc.  Its a submenu of the main Settings menu I believe (sorry i'm at work not at my ATV)

THANK YOU! That was it! I didn't see "Custom Settings" menu at the bottom of the Settings Sub-Menu.

i made a turtorial if you want to delete it from your aTV

Thanks..I found it too with your help.... look under ATV settings...not Nito's

wanted weather...just not Indianna's

Thanks! I removed the weather and the all black screen was killing me.

The link to the tutorial <How to remove NitoTV weather menu> is not working. Was anybody successful to remove it? I have no maintenance menu either. Tried to install smbc but still no mm.


Sorry to bump an old thread but I installed the MainMenuWeather plug-in and didn’t like it very much. After removing it from NitoTV, I was left with just a plain black bar at the top. How can I get back to the default setting before I installed the plug?
EDIT: Nevermind, found it :slight_smile:

Would you mind sharing what you did?  I have the same problem with the black top half of the ATV2 screen after removal of the nitotv mainmenuweather app.

It appears that once you install that script, you get a “Custom Settings” menu option underneath the original Settings menu from the main screen. It’s the settings menu that is located at the very end that Apple gives you by default. If you click all the way to the bottom of it, underneath “Go To Sleep”, you’ll “Custom Settings” and that’s where I found the option to set the top portion back to default. Hope that helps!

can you change the area to where you live not indiana?

Not sure if this will help as I haven’t tried it yet.

Thanks again to the poster who pointed out the extra settings menu way on the right side at the bottom - I lost my top menu images once before and fixed it and forgot how til i read the post (which helped me the first time…)

Thanks, using the setting menu, I was able to change the weather to my location. You have to lookup the WOEID for your location and input it. Works great now. I’ll work on changing the black screen to another colour.