NitoTV and TS_VIDEO files

I’m fairly new at this, so maybe I’m missing something simple, but here’s what’s happening…

I’ve ripped a movie (“Flawless”) and copied it to the AppleTV using Cyberduck. The directory structure is:

   Movies/My Movies/DVDs/Flawless_US/TS_VIDEO

I go to the DVD menu, then to setup and set the DVD import location to be the same path as above. Then I go to the DVD>files menu, and can select Movies>My Movies>DVDs…then it just hangs.can’t go forward, can’t exit out.

Any ideas what is going wrong?

A couple of things may be causing this, but here are the solutions.

  1. Make sure you have installed the mplayer codecs. This can be done through the DVD > Settings > Install Software > Install mplayer codecs
  2. If you ripped the menus from your DVDs as well, you will need to enable this option. DVD > Settings > Enable DVD Menus

OK, I’ve installed mplayer codecs (as well as running the smart installer) and checked to make sure the DVD menus option was on. I still have the same problem.

If I try to play the VIDEO_TS files using the “files” menu, I get an error saying that I am not authroized to play this content. If I try to play it from the DVD menu option (which I assume is NitoTV) I can select the files sub-menu, but then when I click on the folder, it hangs, and eventually reboots the aTV.

Being able to play from the VIDEO_TS files is my preferred method, as I don’t have to convert to a lesser quality format. Please let me know what else I can do.

Thanks.

For DVDs, make sure the playback setting in DVD > Settings is set to mplayer. If it is set to Quicktime, DVDs will not play.

Thanks, I did check that. Still no good. There aren’t any issues with folder names or anything, like not being able to have spaces…? I’m kind of at a loss, since the installation seemed to go very well.

Do you still have the file locally on your Mac or PC?

If so, try playing it locally with your computer. If it plays that way then we know it’s not a problem with the file itself. Even so, you might want to delete the file and FTP it again.

When I play the DVDs I’ve ripped in the aTV I just click on the main DVD folder in the files menu. You don’t have to go to the VIDEO sub folders.

Actually, when I go to the DVD menu, I choose “files”, and it brings up a page that says “Movies” at the top, with two folders listed, “My Movies” and “My TV Shows” (these are the two subfolders I created on the AppleTV in the Movies directory). Now I can’t even drill down from there. As soon as I click on “My Movies”, it hangs.

Is there any other way to play VIDEO_TS files?

I do still have them on the Mac, and they seem to play fine.

When you say, “DVDs I’ve ripped”, what format are they in? I seem to be able to play DVDs I’ve ripped to other formats, just not VIDEO_TS files.

Has anyone had any success playing VIDEO_TS files on the AppleTV?

If so, can you give me a rundown of your setup (appleTV firmware version, ATV Flash version, etc.) and how you’re doing it?
If other people are getting this to work, I’m considering a factory resert and complete re-install, but that would mean re-syncing my media, so I’d rather not if I can help it.

Thanks!

I’m having the same problem. A friend and i have tried everything to play DVD files without success and we can’t find a step-by-step instruction anywhere. Besides, AppleTV has a bandwidth limitation for playing native DVD files, doesn’t it? And the device has no means to handle fields, either. Some DVD’s are 29.97 video…whether it contains pulldown film or real video material. So, to review…I’ve not been able to play any DVD rips…or any QT’s that I’ve collected, despite the promise. What’s up with this product? I’m complainin’ but I’m not jumpin’

I have several appleTV’'s - my favorite is 250gb bought here from aTV Flash, aTV Flash Version 3.2 & apple v 2.1

I tried a couple of TS_VIDEO ƒ :

  1. direct copies - drag’n’drop from disc to desktop,
  2. via Mac The Ripper (…if there is some copy-protection…)
  • all films worked 100%, and looked fabulous on my 32" flatscreen, exactly like if I had put them in my DVD-player.

I copy the files to my 500gb MyBook, hook it up to the appleTV, : menu: DVD(nito): files:

so the appleTV plays the TS directly from the HD, no streaming,

DVD-menu is terrible, and the remote is suddenly very complicated :slight_smile:

check nito’s wiki: [list]http://wiki.awkwardtv.org/wiki/NitoTV[/list:u]

good luck!

OK, I’ll eat the crow’s wing…but not the whole bird. Got a DVD of my own to play tonight. However, the original is 2-field video and the playback is not reproduced as interlace…and there is sometimes a several-second delay between audio and video when skipping to different sections (pausing and waiting a few seconds seems to help). The key to playback is to make sure the player is set to mplayer only (recommended elsewhere on the forum)…and to access the file from within the aTV Flash “DVD” menu. It also helps to have each TS_VIDEO file in its own folder with the program name.

Still can’t get the Sorenson QT codec to work (it’s in the aTV list)…but there is forward motion, at least…

With some help from aTV, I’ve successfully played DVD material…now I need Sorenson QT and I really want to explore what it takes to get AppleTV to reproduce 2-field video. Any advise?

How were you able to get the DVD material to play? I’m still stuck at step one - Choose the DVD menu, then the files menu, then, in the movies folder I can choose MyDVDs or MyTVShows. Choose MyDVDs (which contains my VIDEO_TS files in their own subfolders) and the AppleTV hangs…

DVD files can be played through the DVD plugin.

  1. Make sure you have the mplayer codecs installed in DVD > Settings > Install Software > Install mplayer Codecs
  2. If your DVDs contain menus, you will need to enable the menu option in DVD > Settings > Enable DVD Menus

I can play back the TS_Video files with menus but I can’t seem to get the fast forward or rewind to work.
All I get is previous chapter and next chapter. I tried holding down the menu key to change keymap but it doesn’t seem to do anything.
Am I missing something that didn’t get installed? Anybody know how to get NitoTV to toggle the chapter vs. forward/reverse playback mode?

Thanks.

forget it pal,
I asked the same question a couple of times and didn´t get any answer (even in Nitos forum).

cheers
Gero

OK, with aTV help, I can indeed play DVD VIDEO_TS files…but they don’t display full screen for some reason. An many quicktime movies play…but some within DVD and others within Files…and in all cases Sorenson QT’s do not play.

Lastly, DVD and most QT’s are stretched across the screen and are squished vertically…which means I must change the DLP’s display ratio. Oddly, this is not required when using any of the original AppleTV features or content.

-dave-

To fix the stretched DVD problem, navigate to DVD > Settings > Mplayer Arguments and enter the following 2 items.

-monitoraspect
19:13

I have given up on video_ts for now. I started using handbrake and converting all of my folders to .mp4 files. The quality is amazing just using the appleTV presets. The only thing that sucks is that you can not use subtitles. (Well, it seems you can, but it is really an all or nothing deal because the subtitles are permanently embedded I think) It also has been very time consuming. On a good day (i.e. - no handbrake crashing in OSx) I have managed to convert 7-8 movies from video_ts to .mp4. Each conversion seems to take 2-3 hours so this is about right.

I have been able to play video_ts folders from both NitoTV and AtvFiles with no problems, but Sapphire doesn’t recognize them at all. I wanted full compatibility with all apps and really liked the search functions (like genre or actor) and getting the metadata online option of Sapphure, so I decided it was best to use .mp4. Funny thing is that now Sapphire isn’t even working for me anymore, so I feel like I wasted the last week on converting for nothing.

I had previously also had problems with nitoTV. I think your best bet is to just use atvFiles. It seems to work the best so far in my experience.

Hope this helps.