nitoTV and Network Connections

I could not get my Apple TV to connect to my Windows 2003 server so I decided to take a look at the posts on this site. There are several posts but I am still unclear as to my next steps. One comment throughout the posts is that if I have an Apple TV with 1.0 code it will work. Since I just bought my Apple TV a week ago then I know I do not have the original 1.0 code. Can I get a clear answer on whether the nitoTV Network feature will work or not on my Apple TV? If yes, is there a good tutorial on how to set this up other than what is on the Wiki? If no, is there any plans to add this feature back?

The basic error I receive is “Resource Busy”.

Network streaming is supported on all AppleTVs. The original AppleTV units will support an extra protocol called ‘AFP’. This is a protocol specific to Apple devices, and is not usable when streaming from a Windows machine.

Regarding the error you are receiving, the most likely cause is a rogue share point setting. If you send over the settings you currently have entered for the share point in the nitoTV > Network menu we can look them over for errors.

I think this page will help you:


I’ve tried this as well, doesn’t work.

I am a long time user. Last night, after upgrading to aTVFlash 4.0.1, since I previously upgraded to ATV 3.0.1, I am still having problems with nitoTV and Sapphire. I am not able to connect to my NAS drives via SMB. This worked just fine on ATV 3.0 and aTVFlash 4.0, but not on on aTVFlash 4.0.1 and and ATV 3.0.1. Can you please help?

When I try to run the Smart Installer to get the other utilities installed, I get the following message.

nitoHelper{180}ERROR:pax failed with status:1, installation aborted

Thanks for your assistance!


I have the same problem. I am using aTV Flash since 3.0 and everything was fine. But now after editing my mounting point in 4.0.1, I have mount_smbfs missing, cannot mount. And I am not able to connect to my network. Is it a bug in version 4.0.1 ? Or I did something wrong ?

help us fast…

Highly doubt thats going to happen to be honest.

Really disappointed with Fire Core LLC support.
I have emailed and called them with no response in 48 hours. Disgraceful considering all the items within atvflash are freelly available and what we have essentially paid for is a support premium.

I’ve just checked this subforum and littered with threads for assistance for mounting shares in nitoTV and looks like there is no response from atvflash support with a fix. Shocking.

I’ll give it another 48hours, if they do not respond or resolve then I will contact my credit card company for a refund and restore my apple tv back to default.

ATVFlash users,

I wanted to share that I was able to fix this issue last night with help from the ATVFlash folks. I don’t know why, but it appears that my Smart Installer files were somehow corrupted. I followed the instructions below and it resolved my issues, so it may help you. I’m able to connect to my NAS drives via SMB and everything seems to be working fine. Yeah!!

To re-install the Smart Installer, ensure the AppleTV has a working Internet connection and follow these steps.

  1. Connect to the AppleTV via FTP as described here:

  2. Navigate to the Documents folder, and remove any DMG file(s) you see there.

  3. Re-run the Smart Installer.
    Note: After you delete the .dmg files, the Smart Installer will need to download from the internet that is rather large (300mb). It took about 15 mins for me, but could take longer.

I hope that this helps you like it did me.

Thanks for this information, I’ll give this a try tonight and report back. If it fails I’ll be looking for a refund and switch to the free installer which also has nitoTV.

Very annoyed ATVFlash support haven’t acknowledged emails/calls/threads about this issue. Disgraceful.

Thanks for this tip, it worked fine for me. I am now able to access my Network as I was doing before… Just in time for the week-end… Thanks again


I remove the dmg via FTP and re-ran the smart installer but still get the same error when trying to mount to my network share!


Network Mount Failed!

mount_smbfs(198) malloc: ***vm_allocate
(size=3221221376) failed (error code=3)
mount_smbfs(198) malloc: *** error: can’t
allocate region
mount_smbfs(198) malloc: *** set a
breakpoint in szone_error to debug
mount_smbfs: session setup phase failed:
syserr = permission denied


Mount Name: TVShows
Mount Type: smb
Mount Address:
Requires Authnetication: Yes
User Login: nairnet\appletv
Password: ********
Volume Path: TVShows
Auto Mount: On
Use Custom Path: Off

AFP & SMB not work at all!! I tried all the tricks from this forum… spend many hours but blah.
Apple TV is waste of money!! Nothing works on it.

I gonna buy this:

I think it’s solve all my problems. :wink:

also have this same problem. no can do… :cry:

If you’re getting a similar error, there may be an issue in your share point settings. If you post the settings here, or email them ( we can look them over for errors.

I’ve also tried the instructions (2 twice), doesn’t work. When I go into nitoTV / Network, I can see “MyBookWorld” but when I click on it I get the same old message about deleting the dmg file in Documents. Round and a round I go…

Please help quickly so I can get this to work, this was the only reason I paid for your software - so that I could connect to my NAS WD drive.


If the message you’re getting when trying to get you network USB drive to mount is “AFP is not enabled properly,” followed by the confusing instructions, “Smart Installer with a 1.0 recovery dmg in ~/Documents will fix this issue,” here’s what finally worked for me, all of its pieced together from posts here:

  1. Open your terminal, and enter rm ~/.ssh/known_hosts

  2. Then go to the wiki for enabling AFP: and follow it’s instructions.

This finally allowed me to mount my drive, and use Nito. It’s still not perfect – I can’t see all my drives, and the movies don’t stream as seamlessly as they once did. But this is at least a beginning

Having same issue. Can’t mount. Want to try to connect via FTP and remove the dmg. Unfortunately I can’t connect via ftp either. I have 2 ATVs. Does anyone know how I can determine the IP address so I can use Cyberduck to remove the DMG?

The AppleTV IP address can be seen in the Settings > General > Network menu.

Thanks, but are these for a PC or a MAC? Sorry, I didn’t specifiy but I am on a Mac. Thanks for the help.

Has anybody figured this out? I am having the same issues on this post as well as others. The only reason I bought this software was to use the network share and access my movies on a hdd connected to my imac… I have painstakingly done every single thing anyone has said to set this up in every forum I have come across. I am starting to think that this is not going to work and am thinking of reversing my transaction. This should not be so difficult. I can find my computer but cannot access files… I can ssh to the apple tv with cyberduck but I KEEP GETTING THESE STUPID MOUNT FAIL errors??? I have done different things and have received different ones… P.S. I also bought my apple tv today as well so it is the new one… no recovery 1 dmg or whatever works… THIS SUCKS!!! help please. thanks in advance, j