Nito TV Network problems

Hi all,

Despite several emails to aTV Flash’s supposed help desk, I am still unable to rectify my problem.

When I go to Nito TV> Network, to set up my network to allow streaming to my Apple TV, the unit just resets itself and I get the Apple TV logo come up. This happens all the time! At first I was getting the input screen – which wouldn’t allow me to stream, despite setting up as per their instructions, but now I get nothing. I AM TEARING MY HAIR OUT!!! :evil:

I’ve updated to the latest version of aTV and am running the latest Apple TV software. Anyone have any ideas?

Pleeeeease help,
Darren.

Just to update…

In the last couple of hours when I try to set up my network on nito TV I now get, ‘An error occurred. Press Play/Pause to reset your Apple TV’. This is obviously a vast improvement on the Apple logo that would just pop up instead of taking me to the network setup page, but it’s still not doing what it should. HELP!

Many thanks,
Darren.

I was getting the same vague error when I was trying to mount a drive (“An error occurred”) and finally got it working tonight. Here’s what I did, perhaps your situation is similar:

I was trying to mount one of the external USB hard drives I have connected to my Airport Extreme base station, I first launched the AirPort Utility app and selected the File Sharing tab under the Disks section. I confirmed that I had Enable File Sharing checked on and I had set the Secure Shared Disks config to “With a disk password”. When setting up the mount point in nitoTV, I had only entered a password, and left the user login blank, since I thought that was all I needed to access the hard drive connected to the base station. I’m pretty sure it was the blank user login that was causing the vague error.

I launched the Keychain Access app to see what was saved for the Airport Disk Password I had set and, sure enough, it had also saved my user name. So, when trying again to create the mount point in nitoTV, I made sure I had the following:
Mount Type - smb
Mount Address - .local
Requires Authentication - Yes
User Login -
Password -
Volume Path -

Actually, on my first try including the user login, I had the wrong password entered and I got an error message saying that permission was denied. But I was happy to see that error instead of the vague error I had been getting. I entered the correct password and it mounted just fine, although there was no notification that it had mounted. But when I went to nitoTV -> Files, I saw the drive mounted there.

You didn’t mention whether you were trying to mount a network drive (like me) or a shared folder on your computer, and you didn’t mention whether you’re running Windows or OS X on your computer, but I hope my experience is still helpful in some way.

  • Jake

Jake,

Thanks for taking the time to reply to my query – something that aTV Flash themselves can’t seemingly be bothered to do. So much for tech support, huh.

I’m running OS X and trying to share from a file on my iMac. My problem is I can’t even get to the Network screen on nito TV. When I scroll down to Network from the nito TV menu and press ‘play’ on the remote to open it, it just gives me the error message. To be honest, it’s really starting to PISS ME OFF!!!

Cheers,
Darren.

FYI, there is an updated version of nitoTV (available through the Maintenance --> Manage Plugins menu) that should resolve a number of issues revolving around the Network menu.

I have the same or a similar problem. I have the absolute latest version (unless a new one was posted in the past 12 hours). When I select [Network] under NitoTV causes a reboot or an error message prompting me to press play/pause to reboot…This occured after I spent most of a weekend trying to mount a drive/directory of my server following all the directions in the manual. Initially the [Network} function allowed me access, until I ran out of other options and tried using the custom path option. Once I turned that on, and entered an address in the space provided, selecting Network causes a reboot or error and no longer allows access to the menu so I can’t remove the erroneous entry. I’m beginning to regret paying so much for a product that is not ready for commercial launch.

A new version was actually made available this morning. :slight_smile:

If you’re still having trouble, the saved share points can be manually removed by connecting via FTP (http://wiki.atvflash.com/index.php?title=FTP) and removing the ‘mounts.plist’ file that resides in the Library/Application Support/nito folder.

Thanks. I just ran updates and selecting Network still results in an instant reboot with no access to the submenu. I’ll try the procedure to manually remove the entries. If I can get back to the menu, I’ll need further help finding the right protocols for connection and mounting of my media server (unRaid; a linux-based server). Before I got locked out, I got the attached error message FYI…

Finally got it mounted properly. Thanks for the help.

Thanks for all your postings on this subject guys. I just posted a little while ago, about the same Network phenomenon problem, and posting about how to delete the
Mounts in Networks, after they don’t work, and are stuck there. By mere luck, I thought that perhaps the way to go was to delete that Mounts.plist, and voila, you helped
me by mentioning that that was the way to do it.

Someome just sent me an email stating " Having the same problem. Where was the plist stored that you deleted. I
have several bad network names to get rid of." Here is an answer that was sent to me from another post:
“The mounts can be deleted through the view/edit settings menu. Highlight the mount in the nitoTV --> Network menu, press the right arrow, and select ‘remove mount point’ from the bottom of the list.” Hope that helps whoever sent the email to me.

I had to add the SMBFS kernal extension to rc.login to get this working

Nitro > Settings > Utilities > Kernal Extension Manager > SMBFS.kext > Add to rc.login

 

I am looking for this path yousupplied, and in my list under kernal Extension Manager, I have no SMBFS.kext at all.

I am also gettign an error stating the SMBFS is missing, when trying to mount. I am guessing the absence int he list and the error are related.

Anyone know where I can get/download SMBFS.kext  to add?

(sorry, had forgotten to log in before)

Has the Smart Installer been run?  This is required for network streaming (will automatically install SMFS.kext) and a number of other features.

firecore.zendesk.com/entries/247181-finishing-the-installation

I purchased atvFlash software yesterday Oct 5, 2010.

I have difficulty as well in setting up nitotv to share or connect with my macbook pro.  I have gone in detail through the setup instructions and also the forums at length but no use.  Spent many hours to try to get it working. 

I am truly frustrated and need help to get it set.  The main reason for me to get appleTV was to be able to stream from network.  If this does not then I am going to ask for a refund or contest with my credit card company.

Appreciate your quick reply. 

PS:  I have read on your support forum a number of frustrated people having similar problem with unsatisfactory response from your help desk.

The most common cause for connection issues is an incomplete setting somewhere in your share point settings. 

If you want to post your share point settings here (or submit a support ticket) we can review them for you.

I have submitted a support ticket.  Thanks.

I have issues as well that nobody seems to want to help with.  I could not get anything to mount on nito.  Thru no help of this site (I got the "email me your settings" response, did so and got dusted off with no resolution)...I got it mounted - it didn't really say I got it mounted, but finally it showed up in XBMC/Boxee and i can access everything on my PC and two separate usb connected external hd's - but nito and sapphire only read one single shared folder.  Any attempts to unmount and mount again lead to failure EVEN with exact same settings...but yet, xbmc still reads it


What gives?