nito Smart Installer problem

Attempting to set up aTV Flash for the first time I encounter the following issue…

  • Restored Apple TV to factory default.
  • Updated Apple TV to latest OS.
  • Booted up with the flash drive and successfully installed aTV Flash.
  • Went to the “Maintenance” > “Settings” menu and ran the “nito Smart Installer”.
  • The Mac OS downloaded and installer started, then exited with a BRIEFLY displayed error regarding incorrect permissions.
  • The display then went to a screen outlined by a white box and titled “Install Partial or Failed” with a blue “Exit” button displayed at the bottom.
  • When I “Exit” that screen I’m returned to the Settings menu that shows the “nito Smart Installer” status as “Last Run: Never”
  • Selecting “nito Smart Installer” again in attempt to re-install returns me to the “Install Partial or Failed”.
  • Restarting the Apple TV (incidentally there is no startup sound at this point for the Apple TV splash video) and attempting to run the nito Smart Installer again displays the “Install Partial or Failed” screen.

Any thoughts and help would be appreciated.

Thanks,
JW

You may try re-running the Smart Installer.

To re-run the Smart Installer, ensure the AppleTV has a working Internet connection and follow these steps.

  1. Connect to the AppleTV via FTP as described here:
    http://wiki.atvflash.com/index.php?title=FTP

  2. Navigate to the Documents folder, and remove any DMG file(s) you see there.

  3. Re-run the Smart Installer.
    http://wiki.atvflash.com/index.php?title=Smart_Installer

Thanks for the reply…

I actually got past this error by installing the nitoTV plugin and then re-running the nito Smart Installer. Is there perhaps an undocumented requirement that nitoTV needs to be installed in order to use the nito Smart Installer?

Thanks,
JW

Yes, nitoTV is required for the Smart Installer to complete successfully. Glad you’re up and running :slight_smile:

I am having problems. The Smart Installer says “It’s Thinking” for about 45 seconds, then the screen goes blank. I never get to the “successfully installed” screen, it just stays blank. I also don’t have the “applications” tab when I go into nito TV. Also, the Apple TV menu is very basic and doesn’t look like the ones I see on the YouTube videos people have posted. Anyone have any ideas? Any help is greatly appreciated!

If you don’t see the Applications menu under nitoTV you can enable it through the nitoTV --> Settings --> Categories menu.

Thanks for the tip! I really appreciate it! I’m at work now, but when I get home I’ll check it out. Any ideas on the Smart Installer issue?

I still cant run the smart installer i get an error has occured i tried the above things and no DMG files where the… what can i do?? i keep getting the message “an error occured” and cant instal it… please HELP…

Do you currently have the nitoTV application installed? If not, you can install it through the Maintenance --> Manage Plugins menu.

Hi, and thanks in advance:

In my case, I am redirected to

INSTALL PARTIAL OR FAILED

… kextloader already installed!
… mach_kernel.prelink already patched or unrecognized
… bins installed succesfully!

… XML parser error:
unexpected character h at line 1
old-style plist parser error:
Unexpected ‘;’ or ‘=’ after key at line 1
… mount:/Users/frontrow/Documents/
MacOSXUpdCombo10.4.9Intel.dmg failed

and the blue exit button. I did the filezilla thing, no DMGs, installed ALL the plugins and still nothing…

What can I do or is my software corrupted…?

Hi All

I am experiencing exactly the same issue as above (install Partial or Failed). Tried aforementioned solutions but still nothing. Alexmun above has provided verbatim of the message received… something to do with Parser Error? Please note I am installing from Windows Vista; part of the error message refers to MacOSXUpdCombo 10.4.9Intel.dmg I dont know whether this has any bearing on the problem?? Everything else installed seamlessly until this point.

Thanks.

I am having exactly the same problem as the previous two posters “install partial or failed”. I have tried everything in the earlier email including uninstalling and reinstalling nitotv and then rerunning the smart installer. When I use cyberduck to view the documents directory on the appletv there is only one .dmg file present (“MACOSXUpdCombo10.4.9Intel.dmg”) and it is only 5.5 kb in size. If I copy the file to my mac and try to open it locally I get an error: the following disk images could not be opened, reason : “not recognised”. Does this mean the DMG file is corrupt? thanks - Tony

Yup I’ve got the exact same problem as alexmun, rekmira and robbycoo.

New version of the installer maybe?

You may try removing the downloaded file and re-running the Smart Installer. Ensure the AppleTV has a working Internet connection and follow these steps.

  1. Connect to the AppleTV via FTP as described here:
    http://wiki.atvflash.com/index.php?title=FTP

  2. Navigate to the Documents folder, and remove any DMG file(s) you see there.

  3. Re-run the Smart Installer.
    http://wiki.atvflash.com/index.php?title=Smart_Installer

Hi
That seems to have worked now & the DMG file is much larger
Thanks for your help

I tried the recommendation, however, when I navigate to the documents folder through filezilla I do not see any DMG files? the only files i see are: ATVFInstall.log and nitoInstall.log. Frustrating.

Does your AppleTV have a working Internet connection. The Smart Installer requires a fairly large (~250mb) file download from the Internet.

Hi all,

1st time poster on the forum and I hope you can shed some light on my issue and apologies for the long post. Before starting I’d like to say a big thanks to everyone here (kudos to guardianmax). In the past, if I had run into any issues, this forum has always been a fantastic source for finding solutions.

OK onto my issue. Fundamentally, since running the 4.1.3 update from the maintenance menu, the Nito Smart Installer will not install, regardless of where you attempt to install it from, either in the Nito setup menu or the ATV Maintenance setup. Another odd thing also occurred which, which was the reason for trying to run the Smart Installer in the 1st place. When I did the initial 4.1.3 upgrade, I went to the Maintenance > Install Extra’s menu, but there was no listings of the plug-ins available. It just had the Menu Heading “Install Extra’s” and nothing else. This then prompted me to actually download the 4.1.3 Update from the ATV site and do a complete reinstall, inclusive of reverting to the ATV’s factory default (3.0.1) version. I let the ATV update to 3.0.2 take place and at the same time also decided to hardwire the ATV to my network to ensure reliable throughput when downloading the plug-ins and updates needed to get things up and running.

After doing all the required steps to reinstall from scratch, I once more get to the point where I require to run the Nito Smart Installer and it errors out again with a partial install. When I view the partial “MacOSXUpdCombo10.4.9Intel.dmg” file via FTP to the ATV, it is exactly 5663 bytes every time. I have obviously tried removing/deleting the dud dmg file and reinstalling, but I just get the same result and as mentioned before, it fails to install no matter where you try to install the Smart Installer from.

Here’s a copy of the nito.log which echo’s the same issue posted by another member in this thread.

[color=#FF0000]2010-06-10 09:41:15.440 nitoHelper[553] Root filesystem already writable

2010-06-10 09:41:15.561 nitoHelper[553] kextloader already installed!

2010-06-10 09:41:17.740 nitoHelper[553] mach_kernel.prelink already patched or unrecognized

2010-06-10 09:41:18.072 nitoHelper[553] bins installed successfully!

2010-06-10 09:41:18.443 nitoHelper[553] XML parser error:
Unexpected character h at line 1
Old-style plist parser error:
Unexpected ‘;’ or ‘=’ after key at line 1
2010-06-10 09:41:18.443 nitoHelper[553] mount: /Users/frontrow/Documents/MacOSXUpdCombo10.4.9Intel.dmg failed[/color]

Any advice given will be gratefully received!

Thanks…Ian

Seems like it may be an issue with the dmg download (possibly due to a network issue).

Try this:

  1. Remove the DMG file from the Documents folder.
  2. Download the file to your computer using this link: http://wsidecar.apple.com/cgi-bin/nph-reg3rdpty2.pl/product=13207&cat=60&platform=osx&method=sa/MacOSXUpdCombo10.4.9Intel.dmg
  3. Copy that file to the Documents folder on the AppleTV.
  4. Re-run Smart Installer.

FYI, the Smart Installer will only need to be re-run when installing an AppleTV system update.

Thanks for the advice Guardianmax. Unfortunately it appears the link provided for the download is broken or been moved on the Apple site. Had a go at finding it myself, but no luck.

Cheers