Nito Smart Installer Not Downloading

Hello, today i tried to download the Nito Smart Installer and it says that the download is not available, anyone knows a workaround ?




I am in same boat, I think the nito site is down and has been since yesterday. Guess they will fix after long weekend. Bummer

I have the same issue as you are – so far no one has posted the solution.


Well, this isint a problem with firecore, it the link on apple that is broken. The best way is to download the file at another site, and then manually put it with ftp client in the documents directory. Here is an alternative to apple website and it’s ok , i allready installed it.



Kevin Guerreiro

What is the procedure after downloading the url you posted for


How do we update the apple TV (silver) on the 10-4.9 and will this solve with the Nito Smart Installer?


Thank you

It’s easy, just download a ftp client, cyberduck or filezila, connect to appletv with ip or appletv.lan , login/pass is frontrow, and put the dmg in the documents directory.




And then go to appletv and install.




How you install it on appleTV??!

Go to Maintainance, Settings, then run Nito Smart Installer.




I did everything, when I run smart installer it gives me the same message. “Unavailable”.   

that means that youre not putting the file in the correct place.

I am having the same problem.  i did all of this correctly, it runs (says it’s thinking) and then when I reboot I still have no external hard drive showing up… ???


Did anyone come up with a workable solution as to why this is happening? After all Smart Installer is a pretty major piece of the ATV Flash puzzle. I’ve followed the alternate instructions to download the software directly to the ATV but like others, I can’t get it to work. If someone could write out a detailed instruction list as to how to upload the file to the ATV, it would be greatly appreciated. Until then, I’m kind of dead in the water. 

Any help woulld be greatly appriciated. 

Kind Regards


The process I understand from you would be:




open cyberduck


enter the Apple TV ip address, re: userid: frontrow password: frontrow

it will links to /mnt/Scratch/Users/frontrow

open folder “Documents” 

In that body of folder under “Documents” drag and drop the file. 

Go to “Maintenance” > “Settings” > nito Smart Installer > (click) to run. It will say “It’s thinking” as it should be updating the OS to 10.4.9

I hope this helps?


On other Apple TV (Silver) says “Install Partial or Failed” – any idea what causing this?

Finally, it worked for me.

that means that probably you have a corrupted dmg, download it again.

Firecore is strangely silent on this issue! What’s up? A major functionality issue and not a peep,…


By the jove, you are correct on the corrupted dmg.  Safari had to “mount it” and I had to block it from attempting mount the image file. All went great!


Glad yo help. This isin’t a firecore problem, the download link on apples webpages does nothing, so probably they stoped giveing support on that update and removed from their servers.