Nito Network SMB Connection - Can't Connect

My Setup:

Apple TV with latest aTV Flash version and lastest Apple TV versions. Updated today.
Linksys SRX 400 Wireless Router connected to Internet DSL Modem.
2GB Iomega Home Media Network Hard Drive connect to Router via ethernet - Hard Drive contains hundreds of movies
Apple TV connects wirelessly to router and iTunes on MacBook
MacBook Pro connected wirelessly to Router

I want to connect in order to watch the hundreds of mp4 movies on the Iomega Network Drive but cannot get it to work.

My MacBook Pro and 3 other Windows PCs on my home network can all connect to the Iomega Home Media Network Hard Drive wirelessly and watch the movies no problem. I cannot however make a successful connection with the nitoTV Network feature via smb connection and I was following the demo video on aTV Flash website exactly.

Has anyone successfully connected? Do you have a similar setup? Did you have same troubles? What’s the fix if you have found it?


It could be an issue with the share point settings currently entered in nitoTV. If you want to post or pm your settings it would help in troubleshooting.

SUCCESSFUL CONNECTION ESTABLISHED. If it is helpful to anyone, this is what I did:

  1. nito Smart Installer run until complete

  2. Unplugged / Re-plugged Apple TV to complete a restart

  3. nitoTV menu then selected “Add Manual Share Point”

  4. selected “Create Manual Share Point”

  5. Entered the following settings:

    Mount Name: HomeMediaDrive (this is the name I gave the drive when I set it up)
    Mount Type: smb
    Mount Address: HomeMediaDrive.local
    Requires Authentication: No
    Volume Path: Movies (this is the folder on the drive where I have all my movies)

  6. Selected “Save Mount Point”

  7. Back to the nitoTV “Network” menu and selected “Mount”

  8. Then from the nitoTV menu selected “Files” and my “movies” folder was successfully displayed and accessible with all my movies1

I’m having a similar problem only I get the following message when trying to mount:

Network Mount Failed

mount_smbfs: tree connect phase failed:syserr = No such file or directory

mount_smbfs: tree connect phase failed:syserr = No such file or directory

I get a similar message using AFP

NFS completes a long mounting phase but does not show any drives conned in File Menu…

Please help…

Reviewed folder name on TC - actual root directory name was different than drive name… used root directory folder and it connected… still not accessing my media, but closer…

The drive name is case sensitive. You may want to ensure the drive name is being entered with the case in mind.

I know this is a very old topic, but I need help setting up my HD with nitoTV. I have been trying for three hours now to no use. I attach an image of my router page where the HD is connected via USB. My HD is a normal Western Digital 2TB USB drive connected to the router’s USB port for sharing on a network. The drive is visible on my MAC.
My Apple TV is gen 1, with aTVFlash v4.6.
I tried following the steps in the nitoTV guide but I cannot seem to get it to connect!
Can someone pls post the info I need to write in the nitoTV Annual Share Point page?