NFS not connecting


I have Infuse Pro 5.7.1 and I am trying to add a Share using NFS and I am getting the error “An error Ocurred”.
I have an APTV 4k. It was working before.


What type of device are you streaming from?

Have any updates been installed or settings changed recently?

I am using Apple TV 4K.
No changes or update has been installed as far I know.

I think the question was what kind of device you are streaming “from” not to. You had ATV 4K in your original post. What kind of device are your files stored on and served from and have any changes or updates been done on that machine?

I have a QNAP NAS.
It was connected to the NAS using NFS before.

Recommend that you restart the ATV 4K first. If that does not solve your problem of NFS shares not connecting, then you should power cycle your QNAP NAS. Check the NAS logs to see if there are any issues on that end. Occasionally, you can get issues that may impact the file sharing services even though the NAS drive itself seems to operate fine.
Revert back here if neither of these two steps work.

I had the exact same thing happen to me. Have a Qnap TS212 going through a synology 2600ac with an AppleTV gen4 SMB share. Have had to reconnect 2 times to the Qnap server. Next morning open Infuse disconnected again. Becoming really annoying. This set-up has been bulletproof for the past year. As a couple days everything has gone to crap. Also, when I reconnect the SMB. I don’t get the new nifty screen layout with Recenty viewed…

I happen the same thing to me in a Synology the folder can be accessed from Mac from Windows from anywhere less from infuse.

I just moved it out of volume and it makes the same mistake.

To work I have to create a new folder once created the renaming and I can not access infuse the VE but fails to change from another system works perfectly.

It seems an infuse error that remembers the previous configuration for that same name and gives error.

Not sure if this will help, but after the recent iCloud problem, one device suddenly could not access a certain share on my Synology NAS. It had worked before.

I checked the NFS permissions on the NAS and found that somehow they had changed. I set them properly and solved the problem.

Seems weird, I know. But check your NAS NFS permissions.

The permissions are correct.

I access from either side less from infuse.

It happened to me before the iCloud problem.

On QNAP NAS for NFS you need to whitelist the device IP or Subnet you want to allow to access the shared folder. Control Panel > Network Access > Privilege >Shared Folders > Click on Folder > Permissions > Permission Type > NFS Host Access > Add Host IP range.

Ha ha :wink: clear if it is not going to work.

You should fix this infuse problem with the folders shared by NFS.

This problem takes a long time and the technical service does not do anything in the post open one of mine and several users.

But it seems that they are silent to such a big problem.

Internally I think infuse remembers the link to the folder shared by NFS and any changes after no longer allows.

It happens in both IOS and Appletv.

Does not give a connection or access error gives a system error or something like that.

The folder sees it and enters but gives the error.

Does this happen only when moving volumes around, or does it happen in other cases as well?

If you’re not moving volumes around a lot, it may be best to simply delete the old share and set up a new one.


If I delete it (5000 movies) and I think another works.

But I want to use that folder name.

If renaming the created folder stops working, the error appears.

If I delete the connection and create another NFS connection see that new folder renamed but it gives the error.

I also works perfectly on other devices Kodi IMac PC etc.

It just doesn’t work on infuse.

I do not want to change all devices only because infuse does not work well because in the next change will happen again.

If you are able to send in a quick report the next time this happens it would help us track down what is going on here. Thanks!

The next time the error occurs?

I’m sorry I’m laughing.

The problem is still not solved.

I can not access that folder by NFS or AppleTV or IOS.

The problem does not exist on a PC in a Tvbox on an IMAC all access.

I sent the error code and you did not listen for that I’m in this post.

Sorry for the confusion.

I’m not saying it’s been solved, or that it’s not something that can be improved. Sending in a report from your device simply allows us to see exactly where Infuse is running into issues with your particular setup, which will hopefully allow us to handle cases like yours a bit better.

This K6QCE

It’s the third time I send the code and they don’t listen.

I sent it to the help mail and it happened to you the code.