Newbie. First Post. Trouble jailbreaking 4.3

I just jail broke another Apple TV. The seas0n pass 101 instructions were easy to understand and the software was easy to use. I had trouble on my Mac then someone told me to use a PC and it worked great. Now to my question, I have a brand new at2 with 4.3. I read the instructions and it says to download a different version of seasonpass for 4.3 and earlier. I downloaded seasonpass-win093. The proccess looked like it went well. I put it on the TV and I get the apple logo then the screen goes blank. I assume it is tethered boot now. I wanted an untethered boot. Is that still possible? Should I redo the proccess with the new season pass? I’m a newb so please excuse me if this question has been asked a thousand times. I am very new at this so please use small words : )  Thanks.

well, it seems that you already jail broke it on a tethered release, so you can’t go back if you didn’t save blobls. now get the neewest verion of season pass which will jail break on 5,3 untethered

Thanks for quickly getting back to me. So… just download the new seasonpass and re-do the jailbreak per the jailbreak 101 instructions say?




p.s. you could have used the latest seasonpass on the first jailbreak. It should be written clearer in the 101 instructions, but using the old seasonpass would have only been nessecery if you were jailbrealing to 4.3 or earlier.

Thanks guys. Much better response than the XBMC forum. They are always disrespectfull.

you’re welcome

I tried to re-jailbreak it. Hooked it up to the TV and got a USB cord and an iTunes icon above it. The ATV light is blinking quickly.

Did you make sure that you had the latest SeasonPass (0.9.5)?    Your symptoms sound like you may have jailbroken with an earlier SeasonPass (e.g. 0.9.3) which was a tethered jailbreak of 5.3.    You need to use SeasonPass 0.9.5 to get the untethered 5.3 jailbreak.


if itunes open during the jail break process you are running an old veriosn of season pass.

you usually don’t get the usb cord message with these current jail break so something went wrong. first, restore the unit in itunes to make sure the unit isn’t bricked then after confirming re jail break



      I used the jailbreak 101 instruction. It says to use another version for 4.3 and earlier. So Thats what I did. I posted that and was told to re-jailbreak it. I downloaded a new seasonpass. It does not say any version just season pass. The old one said Is there another place to get downloads? The only place I know to go is the seasonpass 101 page. Should I go into iTunes and restore it? Not sure how to do that either.


If you right click on the seasonpass.exe file and select properties it will tell you what version you have. The seasonpass on the 101 page is the latest. (.0.9.5)


Yes, it says to download a different version of seasonpass for 4.3 and earlier but you are misunderstanding this.  This is only meant for those wanting to remain on 4.3 after the jailbreak.  Since you are wanting to be on 5.3 after the jailbreak this doesn’t apply to you.  The latest version of seasonpass (.0.9.5) will erase your 4.3 and install 5.3 while jailbreaking it untethered automatically.    

Finally got it to jailbreak. I have bad luck jailbreaking. I used the 0.9.5. Kept giving me errors. “Restore failed” “Error entering DFU mode twice”. I have had problems in the past. Seams like I have to keep jailbreaking till it finnally jailbreaks. Did nothing different after using the 095 version. Just had to do it over and over till it breaks. Thanks guys for your help.