New Media Player won't update

In my Managing Extra’s menu I have both Maintenance and Media Player showing “update”.  When I click on either of them, it goes through the “installing Media player” then says that the installation was successful and offers to relaunch.  Upon relaunch everything is the same and they still show update.  I checked the log and found this:

 

E: Could not get lock/var/lib/dpkg/lock - open (35: Resource temporarily unavailable)

E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

 

I’m not sure I know what that means, but I have tried to relaunch it several times and it doesn’t seem to make a difference.  Can anyone help me out?

 

Joe

 

PS… I had also tried unplugging the unit and allowing it to reboot.  That didn’t change anything, except now the time won’t set.

Looks like I got it fixed.  let’s see if I can explain:

Nitro TV => Manage => Sources => FireCore LLC => com.firecore.fcwebcontrol => More

I then clicked on dpkg configre.  This didn’t seem to do anything.  I then clicked on “Fix Dependencies”.

I went back in and the installations took. 

 

J