New issue with consistency low network speeds

I’m using a Synology NAS, ATV 4K with new Cat 6 cables and a good router. I have had the same system for more than a year easily streaming 250+ Mbps files over NFS. I’m on 6.3.2.

Suddenly and unexpectedly in the past week the speeds dropped. I’m able to stream 1080P files, and intermittently I can do some 4K files but typically I just get the spinning wheel. Speed tests show around 100-150 Mbps. My attempts at fixing so far:

-Tried many different files, seems to happen to all files but more noticeable on 4K high-bit streams
-Changed from NFS to FTP. First test gave me 700 Mbps but after that it would bounce all over the place and now will hover around 5 Mbps (slower than what it does on NFS).
-Tried Legacy streaming, no dice.
-Reboot of all hardware and all up to date.

The ATV can stream 4K from other online sources.

edit; One other random data point, when I navigate to a movie in InFuse, it gives me a spinning wheel just to the right of the movie title. I can still play the file from there, but it seems like it is perhaps struggling to download metadata? I’ve cleared meta-data and it’s downloading again, but it does seem to be taking an extraordinarily long time.

Not sure if this is a Synology thing or a InFuse thing. I’d appreciate any help because right now my system is worthless for all my 4K media.


Maybe you have a failing router?

I’ve switched ports around and have no problem with streaming 4K on ATV otherwise. I suppose it’s possible that it would only affect LAN traffic but it seems unlikely to me…

New cable doesn’t always equate to a good cable. Maybe try another new Ethernet cable. Cheap test.

Sorry I should have said that. I tried two new cables.

Streaming from Netflix and streaming from a NAS re two different things. Packets will be different as well as impact on CPU usage. I don’t know how well versed you are in IT but if you have a way to monitor snmp on your router and NAS you might be able to determine if any packets are being dropped. Additionally if you have a synology NAS with two Ethernet ports and have adaptive load balancing disabled I’d recommend turning that off.

Also try watching with VLC or MrMC. If the same problem exists then you have an issue with hardware or firmware.

An update: I’ve tried various speed tests:

In Infuse, connected cat 6 to Synology via FTP - very poor, 2-900 Mbps but usually 2-50 Mbps
In Infuse, connected cat 6 to Synology via NFS - consistently 100-230 Mbps
In Infuse, connected cat 6 to Synology via SMB - consistently 140-180 Mbps
In Infuse, connected cat 6 to Computer via SMB - consistently 150-220 Mbps

Apple TV speed test to Internet - consistently 385-400 Mbps

So it appears either LAN traffic is impacted (not internet) by the router OR the Synology network card is going…?

My Synology only has one ethernet port. I tried with VLC which I never had luck with, but it seems to choke on high bitrate files also. That said I think it always did in my setup.

However, I was able to transfer a file from the Synology NAS to a computer (Windows 10) at 86 MB/sec (700 Mbps) very consistently. So, it doesn’t appear the network card of the Synology or the router has an issue.

150 to 200Mbps is what I get on mine with both SMB and NFS. Plex gives me around 450Mbps.

I have a synology ds415play NAS and a Cisco catalyst switch.

That being said I’ve sort of stopped using infuse and have moved over to a 2019 shield pro with kodi and pelxkodiconnect addon. The last update fixed their Dolby vision issues.

Why do you get a much faster rate when using Plex?
I’ve got a DS218+, and I stream direct from the NAS using Infuse (of course), but could not see the point in installing the Plex media server on the NAS… is there a benefit?

That seems odd to me. It sounds like you’re suggesting that InFuse isn’t capable of high bitrate 4K files. I’ve been streaming my full bitrate 4K files up to 150-200 Mbps for a year. Suddenly something has changed. Infuse and my system is capable of this.

I’m guessing plex doesn’t have the overhead that SMB and NFS have.

Infuse can do high bitrate. I switched because of lack of Atmos/DTS-X on the AppleTV. Not an infuse issue… an Apple issue.

Your speeds should be good enough. Another thing you could try is disabling transport encryption in your SMB setting on your synology.

I am using NFS as it gives me the fastest speeds.

I can transfer these 2-hr video files in 20 minutes on the network but for some reason infuse is not cable of streaming them? It makes no sense. It also makes no sense that this setup has worked for a year and for no reason something has changed.

Have you tried accessing your Synology via FTP? I can’t seem to stream 4K using NFS of SMB (infuse speed test shows around 15 Mb/s) but when using the FTP option, I’m getting 150 Mb/s and almost no loading time when accessing 80Gb movies.

Hi thanks for your advice but I’ve tried FTP and get very inconsistent speed. On top of that I reliably get 150+ speeds with NFS but the loading time is long to infinite with stuttering to buffer.

If other apps seem to be crapping the bed then maybe you got an issue with your Apple TV?

i don’t think so everything else works great and I can run an internet speed test at 350 Mbps on the ATV

I will try MrMC and see if that works any better, but at this point I’m kind of resigned to trying things that I’m not sure make sense. New ATV, new router. Unless there are any other ideas…

is something else connected to your NAS (usb drive) or are you trying to read and write at the same time?

No nothing else is connected to the NAS.

For some reason I can’t get MrMC to work at all. I can connect to my NAS via NFS and get to the shared folder (video) but can’t see anything inside it…

But I’m checking again now and it seems to be working for most 4K movies except for two. No… now not working again. So it’s definitely intermittent. I was able to start a movie several times then after that it took a minute to start it. For a couple minutes there I was able to start most things. But the weird thing is that there are two new movies I have never been able to start at all, even when everything else seems to be working. It’s almost like those being there is vexing my entire setup. I’m so confused lol