New installer doesn't work

Me: Macbook 10.6.4, Atv Black running iOS 4.2.1. Home sharing and Airplay are both on.


I downloaded and ran the new installer, got to the last step, which ominously said "Installation Failed. Sorry, the installer could not connect to your AppleTV. Help!"


At least for me, the new update still doesn't work. How about you?

yep, exact same problem.

Same problem here too. Can ssh to the ATV, login and open a file transfer session. I have home sharing and airplay on. Running tethered 4.2.1.

Any suggestions?

tethered 4.2.1. is your answer..


it is only for 4.0(4.1 update)

Why do you not read on the forum and all over the internet :

YOU CAN NOT JAILBREAK aTV runnuning 4.1 (4.2.1) at this moment. (It is possible for real experts to do a thetered jailbreake - but if you are such experts you would not need to ask for help here)

What you should do is WAIT for the Dev Team to release a proper jailbreak



Thanks for the advice. I thought that this beta has support for 4.2.1?

Anyhow, I now have it working on 4.2.1 even though the installer fails.


How did you get it working? I have also tethered 4.2.1 and successfully installed atv flash with the installer. But after manual reboot (since tethered doesn't boot alone) I see no difference resp. no atv flash menu.

Add the same problem on my side actually. I had to change appletv network connection to ethernet (was wifi) to get it work (have a complex lan construction so i do not say that is coming from the installer but that can give you some ideas!)

Good luck with your install

Running apple tv 2 jailbreaked (tethered) with 4.2.1. Beta 2 Installer finished with success (no failure message) and everything is working so far :slight_smile:

The ATV flash installer for windows unpacks a tar archive in your temp directory during installation. This archive contains 4 installer packages that I manually transferred to the ATV and then installed with apt-get. The other problem I had was that pwnage didn’t put wget on the ATV during the tethered jailbreak, which I fixed by manually controlling the jailbreak process.

Contrary to the advise against tethered jailbreak for 4.2.1, I don’t see this as such a big issue. Obviously a untethered jailbreak would be nice, but the tethered one is just fine in the meantime.

Next, get plex working…

I have the same problem, IOS 4.2.1 with green poison rc6 jailbreak.

It goes through the process and finishes. Installer says everything went well.

It then restarts lowtide but the maintenance section is nowhere to the found.

It used to work when tethered jailbreak.


Now tried it untethered using greenpois0n rc 6 and install didn't work

im having the same problem i carnt see a maintenance menu 1 i have jailbroke with greepoision rc6 2 i have installed atv flashback 3 in nito i pressed upgraded everthing and it said it couldnt any ideas please

ok i re installed atv flashback 3 times and it works now :)

The installer uses ssh. If you jailbreaked with greenpoisen, you have to klick "inject software" and install the cydia package. This also installs ssh. Then you can install atv black. Hope that helps :-)