New Customer, Lots of Problems

ATV is updated with latest software
ATVFlash is latest software

• Air Mouse says installed where you install it, but where you activate it, it says not installed
• Firefox booted up to a window that said import safari info, I couldn’t do anything, went back to main menu now I get nothing but an apple screen when selecting firefox.
• XMBC is installed and when I select it is say it CANNOT LAUNCH XMBC/BOXEE FROM PATH
• Boxee is installed and when I select it is say it CANNOT LAUNCH XMBC/BOXEE FROM PATH
• When I select a Nito streams and select a stream I get a ERROR OCCURED must restart screen.
• And just like everyone no sound at start up.

Any help anyone can give would be great!
So far I feel like I paid $50 for Couch Surfer!

What version of AppleTV software are you running (Settings --> General --> About)

  1. You may try removing and re-installing Mobile Air Mouse as described here: http://wiki.atvflash.com/index.php?title=Maintenance_Plugin#Install_Extras

  2. Once Mobile Air Mouse is installed and running it can be used to control Firefox.

  3. Before launching XBMC or Boxee for the first time they will need to be updated. More info here: http://wiki.atvflash.com/index.php?title=XBMC/Boxee

I had all of these exact same issues. Still do, actually. I bought ATV Flash in September 2010 and experienced the exact same problems you describe. I find the help on installing/running Firefox in these forums to be underwhelming. I'm still trying to figure it out. I have current ATV software (as of Apr 3, 2011) and Apple TV is updated to latest. I still can't run Firefox, I just get the "Import Settings and Data" window, where it is asking to import bookmarks from Safari, and there's an "OK" button but I can't click on anything.

Searching these forums for "Firefox" yields anything but helpful results.

Regarding the Firefox issue, I've made some small progress, but it's still not an optimal experience:

I couldn't get that "Import Settings" screen to go away, so I held down my remote Menu and - buttons until my AppleTV rebooted (conversely, holding down Menu and + will give you a Black Screen Recovery, let you reset the language and resolution, in case you got yourself screwed up there).

Under "Maintenance > Install Extras" I installed support for Remote HD. 

I bought the Remote HD app ($4.99, and not sure it was worth it) for my iPhone from the App Store, and connected it to my AppleTV to have some kind of mouse cursor control. I found this doesn't work very well, but it seemed necessary to have some kind of mouse for Firefox. [I'm currently wondering if there's any way to get one of those USB/bluetooth mice (small usb bluetooth adapter) to work. That would be a much more reliable and responsive solution if it's possible... but I digress.]

I launched Firefox. This time it had a crash notification from the previous session not being shutdown properly. It asked to start a new session or try to recover the previous session. Using the Remote HD app on my iPhone, and with much frustration and some patience, I managed to get the mouse cursor to click on "Start a New Session". 

The result was that Firefox actually launched with a browser window. The mouse cursor is horribly laggy for me on iPhone 4 using Remote HD, and the Firefox window is placed slightly off-screen, which is frustrating. The left edge of the window is cut off and there is a gap between the right edge of the window and the right side of my HDTV screen. This feels like wasted space. This is with the AppleTV set to 720p resolution. I tried running the app with my AppleTV set to 1080p and the same thing happened. In fact, the browser window in Firefox appeared the same size and resolution in both 720p and 1080p settings, making me wonder if that application actually downgrades the display resolution temporarily to run.

From my experience, sometimes launching the Firefox app takes seveal tries. Often nothing happens when I click it from Nito TV > Applications, and I have to wait a while, keep hitting 'menu' on my remote until it backs out to Nito TV and go back into Applications and try again. Eventually it launches.

I don't know if this will be of help to anyone, but I'll post it just in case.