New ATV2 4.3 (8F305) options?

After reading many many posts yesterday I think these are my options.

Can someone please confirm I am on the right track?

 

I have a brand new ATV2 says 4.2.2 on screen when connected to TV, which is 4.3 (8F305)

  1. I can use ifaith to save the blobs and create a signed untethered jb at current version with ifaith, seasonpass & total commander (on windows)

(following this) http://forum.firecore.com/topic/7279

 

  1. I can use someone else’s blobs for get a signed untethered jb at 4.4.2

(following this) http://forum.firecore.com/topic/7455

 

  1. or I can do an untethered jb at 5.1 (9B179b) BUT no Plex or XBMC

 

Is there a place on here where people are sharing other blobs if I want to try and get an untethered jb at 4.4.4?

Looks possible from this post http://forum.firecore.com/topic/7473

 

Thanks!

Have you saved your 4.3 blobs? I would need them for flashing my atv2 from 4.4.2 to 4.3 :wink:

Follow this post whenever it says 4.4.4 use 4.3(8F305) and you will have an untethered jailbreak

Let me know how you go mate. I have the same problem, brand new atv2 with 4.2.2 installed. I bought this one so I could have an untethered jailbreak with xbmc. I just want to make sure I do it right.