Network Shares never work!

Hey folks;

I have ATV Flash 3.5, AppleTV 2.3 (unit was 2.2 when bought). I’ve installed QuickTime, Flash, Flip4Mac, but I always get the mount_afp error when trying to connect to my network shares. All shares are on a G5 Dual 2.0 running Leopard Server 10.5.6. I prefer to connect over AFP than SMB, even though both are enabled on the server.

When trying to connect to the volumes, as listed I guess by Bonjour, it says I need to press enter to reboot the Apple TV.

Help please!

Thanks

Victor

The network share function will need to be enabled first. Unfortunately since you have a newer Apple TV, connecting via AFP will not be possible. This is only possible on the original Apple TV units that originally came with the 1.0 software.

Take a look at:
http://wiki.atvflash.com/index.php?title=NitoTV_Smart_Installer

I’ve followed the instructions at http://wiki.atvflash.com/index.php?title=NitoTV_Smart_Installer and SMB doesn’t work either.

I have the 1.0 version and have done a complete restore, reinstalled the latest apple software and the lastest atvflash patstick (as of 3/25/09) and can’t get any drives to mount. It either crashes the finder or gives the generic drive mount failed message.

The smart installer says I’ve already ran it if I try to run it again.

Got it working:

If AFP Doesn’t work, try this:

SMB Mount

My Setup:

  1. Apple TV 1.0 with latest version of apple software (as of 3/28/09)
  2. Gigabit Home Network
  3. Airpot Extreme Attached via Ethernet w/ 2TB WD Hard Drive (with Video_TS files) attached to it via USB
  4. In the Airport Extreme settings under the tab “Disks” I changed the settings to “Enable File Sharing” and AirPort Disks Guest Access to “Read Only”

Setup Guide from Start to Finish:

  1. Restored Apple TV to original software (1.0)
  2. Booted up, installed latest apple tv software (2.3.1)
  3. Downloaded atv Flash onto patchstick
  4. Unplugged ATV
  5. Plugged in patchstick, booted ATV - Install Successful Message Appears
  6. Rebooted ATV
  7. Go to NitoTV > Install Software > Smart Installer - Ran, Rebooted after
  8. Went to NitoTV > Network > Add Manual Share Point
  9. Entered this Info:

Name: Movies (use anything label want; i.e. movies, tv shows, music, ect…)
Network Address: Kozloff.local (airportExpressName.local)
Login Type: Guest (unless you’ve setup your Extreme to require a password for disc access, then choose registered user and enter the user/pass)
Volume Path: 2TB Black (Enter the Drive Name Attached to Airport Express)

The next screen (on mine) will look like this:

Mount Name: Movies
Mount Type: SMB <-- Change to SMB!!!
Mount Address: Kozloff.local
Requires Authentication: No
User Login:
Password:
Volume Path: 2TB Black
Auto Mount: On <–Change to “On”!!!
Use Custom Path: Off (Change to “On” if you have separate folders on the same drive you want to jump to directly)
Custom Path:
Extra Arguments:

Choose “Save Mount Point.” You can always edit it later.

Now, go to NitoTV > Files > 2TB Black (or whatever folder is mounted) and browse your movies. Worked for me, hope this works for you too.

AFP automounted shares can be achieved on a brand new AppleTV…

Follow these instructions…

Okay, here goes, I have used these files from a 1.0 dmg.

from sbin directory…

mount_afp

from System>Library>Filesystems…

Appleshare directory and its’ contents.

(If you need them send me a PM, they are about 900K in size)

Please note - To enable write access of the root account, run the following…

sudo -S mount -uw /
sudo -S touch /.readwrite
sudo -S sync

Copy these files to your Apple TV (to the same location)

To create a symbolic link from AppleShare/afpfs.kext to afpfs.fs in /System/Library/Filesystems on Apple TV, run the following command…

cd /System/Library/Filesystems
sudo ln -s AppleShare/afpfs.kext afpfs.fs

To then set owner and permissions, run the following…

sudo chmod -R 755 /System/Library/Filesystems/Appleshare
sudo chmod +x /sbin/mount_afp
sudo chown -R root:wheel /System/Library/Filesystems/AppleShare
sudo chown root:wheel /sbin/mount_afp
sudo chmod +s /System/Library/Filesystems/AppleShare/afpLoad

That works perfectly for me…

Ian

I am getting a permissions denied error when trying to copy the files over. Can you give a brief description of the commands you used.

Thanks,

Mark

Any chance of having the necessary files emailed?