Network Mount Failed -AFPoverTCP

Hi,
I have been tinkering with some setup on my macbook pro and changed the name of my laptop in the preferences.
I did not realise what effect this would have on AppleTV…
In nitiTV Network menu it shows my new Macbook id but when I click on this (what is this link for?) it shows the following message

AFP OVER TCP
NETWORK MOUNT FAILED
AFP NOT ENABLED PROPERLY OR IS MISSING ESSENTIAL COMPONENTS, SMART INSTALLER WITH 1.0 RECOVERY DMG IN ~/DOCUMENTS WILL RESOLVE THIS ISSUE.

Two questions

  1. I think I know what is required in general terms (Instal this disc image). But what exactly are the steps I should take to resolve this issue.

  2. What function have I lost, Itunes still seems to sinc, Cyberduck still works…?
    Factory reset and a complete setup did not resolve this issue.

Thanks
PS I did try another factory rest, install 2.4 installed PATCHSTICK (oh dear!) as well but reinstating atvFlash- I like this better the issue was still there

I have this exact same problem. I emailed the tech support Tuesday AM for an answer. I wanted to setup a network share from AppleTV to my MacBook so I can stream media content that lies outside of iTunes (mostly flv clips), but after going through all the network setup screens in nitoTV, the network mount fails and I get the message you report.

I also find that I cannot enable SSH access in the nitoTV service tools menu, I select it and nothing happens.

The 3rd problem I’ve had is that nitoTV seems to hijack the audio from Apple’s screen saver and photo slideshow functions, has anyone else noticed this? I see an option in nitoTV for slideshows, but it only shows choices for the photo duration time. I surmise that since it exists, it is superceding the Apple built-in functionality, but since there are no audio options, I am not getting sound because of nitoTV.

No reply yet from the atvflash guys :frowning:

I was able to finally get a mount point setup and saved in the nitoTV settings, I had to create a custom path name to make it work. But the volume still does not mount once created. I get a new error message now when I select play/pause on my network name from the network facade, which looks like:

mount_smbfs: negotiate phase failed
syserr = Operation timed out

Could really use some help here guys…

Note: I have correctly setup the folder on my laptop that I want to stream/share in the sharing preferences panel with smb enabled. I wonder if the failure to mount is related to the afpovertcp thing noted in the first post above?