Netflix not working anymore?

I have a jailbroken ATV2 running 5.0.2(4250). A few months ago I noticed Vimeo is no longer working, not big deal for me. But yesterday Netflix stopped working too, although it works perfectly on ipods, ipads, iphones all connected to the same wifi and netflix account.

Is netflix not running anymore on my firmware? I rather not update it becase I dont want to loose all my customization.

Thanks

Same here, no more Netflix.
What happened? Is there a fix for this issue, which is probably big for many users.

Same for me; it stopped working on Nov. 7. I have submitted a trouble ticket.

Same problem. Would someone please reply if you know what is problem. Thanks

Me too, same version 5.0.2.

Netflix support chat say you need 6.0 to use Netflix.

Not working for me for a few days not as well. If we need 6.0 to run it, when is the next upgrade coming out? Or is that a “we are working on it”?

If it was running fine on v.5 why all of a sudden does it need 6? No backwards compatibility? Doesn’t make sense.!!!

I’m in the same boat, no more netflix. May be time to add a Nexus Player to the arsonal

The other odd thing I’ve experienced is that airplay of Netflix from my Ipad air to the atv2 also fails. Net flix is fine on the ipad but the atv2 won’t allow Netflix on airplay. Anyone else see this?

I had the same problem. So today i updated my atv2 with Seas0nPass to 5.3 and mine works again with netflix. So you should try that.

Been thinking about that, will Seas0nPass update atv to 5.3 right?

I followed these steps, install completed. It did nothing. Everything is the exact same. Netflix doesn’t work. Where is the firecore support team on this one? This is a big chunk of the functionality gone. If they can not provide any type of patch or definite date of an update, can they at least provide a means to revert back to stock apple software? Please hurry.

I have 2 apple tv 2. My first updated to 5.3 without any problems but the other one i have to restore with ithunes to 5.3 (Mak sure u use “alt” and restore en seach for the restore file fore 5.3, otherwise you can’t jailbreak your apple tv anymore!) and after that i did the Seas0nPass jailbreak to 5.3. Now that one also works with netflix again.

I just updated mine to 5.3 and it seems to be working.

“Media” is now infuse (I’ve been out of the loop a bit so this was new to me)

But Netflix is working

Nice!

Is there something I am missing? I went through these steps and media is still there and nothing has changed at all.

This worked for me.

Not reinstall the flash, but re-jailbreak. Just run the Seas0nPass and it will update to 5.3!
Then reinstall the flash!

This link:

You need to jailbreak again, not just reinstall the flash. Worked for me.

This worked for me for Netflix, what do I need to do now to get access to my media again?

This worked for me for Netflix, what do I need to do now to get access to my media again?