Netflix issue with ATV black and DNS

Running ATV2 with the latest flash black.

And all of a sudden Netflix wont work, get the famous error occurred loading this content try again later.

Now I have searched for a fix which I think I found, which is to change  the DNS to Google DNS

This is where my problem starts for some reason I cannot get the atv 2 to keep the changed DNS address. It will let me change it says its done but when I go back the old DNS is listed not the one I put in manually. 

I have tried to unplug the unit still no go. Not sure if ATV black is not letting me change the DNS or another issue.

Has anyone seen this and know of a fix?

jrw3711 - I am getting exactly the same problem and share your frustration.

jrw, mine started acting the same way about three weeks ago as well. At first just pulling the power helped fix it, but as of about a week ago, that doesn’t even work.

I also cannot make my DNS changes “stick” either and now my laptop iTunes Homeshared to my ATV2 keeps saying “Authorization Needed”.

I sure hope someone reads this and is able to help… No new software installed recently, so I can’t even start uninstalling things to try to revert to when it was fine.

Is there ANY way to do a “reset” without re-jailbreaking?

OK, although not a fix for my DNS not keeping the changes or my homeshare authorization issues, I did get Netflix back up and running.

In the far right menu called Maintenance>Settings, there is at the very bottom, an option to “relaunch” (I believe that is what it was called, if memory serves… Basically the very bottom selection in the Settings tab), which DOES NOT reboot your ATV2 to the main Apple logo, but kicks you back to your home screen after obviously doing “something”. I figured it was worth a shot and ended up working (for the time being at least… Fingers crossed)

Hopefully that will clear up whatever was causing my loading error in the first place.

It seems curious that our problems started around the same time with the same symptoms though… Just thought I’d share what worked for me last night.