Need som advice and tips on DVD copy and playabilty.

Tried loading the BBC Planet Earth Life discs (from Ripit), but got stuck in the menu. 

Tried ripping “main movie” only with Xilisoft DVD Copy, but that software couldnt crack them.

However the Ripit full rip of the DVD works fine on my Mac. But not on the Apple TV that is…

Had a funny thing going on with Shooter to. The Ripit version plays just fine, but the Xilisoft “main movie” rip didnt work.

So… im having some mixed results here… Ripped my Mission Impossible DVD’s with Ripit, but only 2 and 3 work. MI 1 does not play at all. Works fine on iMac though.


Any hint and tips are welcome. I’ll try ripping MI 1 as “main movie” tomorrow… ugh… eyes are getting tired…

If you’re having trouble with a specific movie (menu or otherwise) please send in a bug report and we can try and track down what’s going on.

Note: A number of DVD related improvements will be available in an update coming later this week.

I use Ripit all the time and the resulting movies are big, but play back fine with Media Player from my NAS. 

Bug report? aha, didnt know one could do that :slight_smile: will have a look at that after work. Thanks James, and good to hear improvements are coming!

Report: Installed the latest update! Things are really faster in the media player now, great job with that Firecore!

The BBC Planet Earth Life series now works! “Human Planet” seems unrippable… not a Firecore problem though.

Mission Impossible 1, still dont play. I’ll do a bug report on that one later :slight_smile: