Need Help Re-Jailbreaking

ok, somethign odd is happening with my ATV2. Running JB 5.0.2 and it has been working great for over 1.5 years. Recently, I moved it to another A/V receiver (headless, with no HDMI) to get audio to another room. A few times, I unplugged it while it was on so not sure if this hurts the OS in anyway. It got to the point where the unit would sometimes show the power light (ON) but no signla was sent to the TV. WHile in this state, Airplay music does not fully wake up the unit. Pressing Menu on the remote kicks starts the wake up process and everything will work after that.

These last few days, I noticed I may have changed the way I turn on my A/V gear. When I turn on the receiver, I sometimes notice the Apple TV lights up. And goes to a blank screen. Trying to Airplay, the unit would just compeltely power off.

Tried cold booting a few times but the issue is still the same, being stuck on a blank screen while the light is ON.

In an attempt to look for the OS version, I used Airply this morning (before the light on the unit was ON) to wake up the unit (before turning on receiver) and everything worked. I have also noticed the unit light sometimes comes on by itself then goes off again intermitently. Not sure if any of this is related.

Just in case I need to re-JB, what is the process for someone running 5.0.2 to re-JB? Don’t understand shsh blog or what as ISPW is but I was able to follow SeaSonspass instructions the last time aroudn to JB this puppy. Also did it for 4.4.4. as well.

Can someone shared some tips on what I have to do exactly yo re-JB this unit? ie. download SHSH blog using iFaith right? and then? What version is Apple still sigjning and what should I do? A little confused but like I said, I can read and follow instructions. If only I could find specific and current info, I may be able to re-JB this unit. Any help would be appreciated.