Need help re-jailbreaking my aTV2

Hi all,

 

First of all I apologise, you must get questions like this from people like me all the time :frowning:

I have had an aTV2 since 2011 or so and I jailbroke it when I bought it on version 4.3 with seas0npass and nitotv + xbmc. It had been running fine and smoothly ever since, but all of a sudden my aTV kept rebooting whenever trying to use XBMC (which is pretty much all i use) then I just couldn’t get my TV to detec the aTV at all. I decided to try and re-jailbreak it using seas0npass, first I tried using the older version as my aTV was still on 4.3 but it was doing nothing, so I tried using the newer version after seeing my apple tv just seems to be stuck in recovery mode. I don’t want to “Restore Apple TV” because I am afraid I will not be able to jailbreak it if I do that. Is there some way I can get it to 5.3 so I can do a tethered jailbreak?

Sorry if I seem a bit stupid I am just really not used to doing stuff like this, I managed to successfully jailbreak it almost 2 years ago I just can’t remember the process as it was so long ago and the firmware has updated now to a point where you can’t jailbreak with the latest version :frowning: Been up all night for about 8 hours trying to fix this… Any help would be appreciated, thanks.

I think its possible that somehow Apple servers saw that you have 4.3, and has deactivated it.  I’m just trying to get to 4.4.4, myself (I do have the SHSHs for everything since 4.4) and right now, its just sitting and spinning and refusing to activate.  I’ll let it go for a bit in case its a server problem, but if that fails, will try to get to 5.1, then 5.3.  I dont really want 5.3 but at least I have the blobs for it.  

I think you are going to be SOL if you never upgraded beyond 4.3 because you wont have the necessary SHSH blobs and as such will be restricted to the restore offered by Apple.  

Avoid restoring to 5.3 if you can since you had a nice UNTETHERED Apple TV, an increasingly valuable commodity these days.  You don’t say if you are working on a PC or MAC, but try using iFaith on your PC to detect if there are any saved signatures for your Apple TV.  iFaith should be able to detect this even if it is in recovery mode.

If you DO have save signatures, try rejailbreaking on a MAC.  You’ll need version 9.3 or earlier since 9.4 doesn’t even list your version. 

If you only have a MAC, you can try right clicking on all the 4.3 versions of SP listed.  If you’re fortunate, an IPSW download will begin.

Remember to have the very latest version of iTunes which is critical to the process.

Since responding earlier, I found that I had to use the older seas0npass version to get my preferred ipsw to install, and apparently for 4.3 and earlier, you must use the older version.  Keep trying if you want to keep it at 4.3, sooner or later it will work (I also had to change cables 3 times and switch to a different USB port.  These things can be really twitchy)

 

Oh, about being stuck in recovery… I’m assuming you only have it connected to the computer via USB.  Just plug it into power, which ought to kick it out of recovery.  Worked for me.