Need help playing Video_TS files!

I have two movies (which I own) that I ripped using Mac the Ripper and play flawlessly using my Mac DVD Player app. I have stored copies of these two movie folders in a folder named “Movies” on my Time Machine and am able to access these movies with my Apple TV using SMB sharing. However, when I try to play them, after a second or two I get the apple logo, signifying a restart of some kind. I have read other posts and have switched back and forth between mPlayer and Quicktime, as well as enabled “Use DVD chapters” option, but I still get a restart. Using Smart Installer I get the message that all has been installed. I am using an Apple TV Take 2 with the latest ATVflash software (3.4, i think).

What can I do to get these movies to play?

I think I have tested everything short of a Factory Restore. I changed mPlayer arguments to increase cache, even. No luck. I just get the reboot.

Anyone have any suggestions on what I can try to make this work?

I performed a Factory Restore last night, however I am still having the same problem on playing my DVD files using NitoTV using an SMB share.

However, I did run some tests to try to locate the problem, and this is what I found:

  • Using XBMC, the SMB share works, and I can play the move (albeit in a small window). This tells me that the SMB share functionality is correct.
  • I then copied the test movie folder with the video_TS to the AppleTV hard drive, then tried NitoTV. The movie played perfectly.

So SMB sharing works and NitoTV from the hard drive works, but SMB to NitoTV does not work for me, and unfortunately this is what I want. Does anyone have any suggestions on other things to try or suggestions on how I can make this happen?

You can try adjusting the cache time in DVD > Settings.

What type of network are you on? Wired or wireless? 802.11g or n?

Thanks for responding! As for my network, I have it setup as a wired Gigabit network with the TIme Capsule and Apple TV connected. I have tried adjusting the cache to 10 minutes with no luck, but that was before the factory restore. I’ll give it shot. Any other suggestions? Again, it does work when the file is on the appleTV instead of SMB, so you seem to be on the right track with the cache idea.

I tried maxing out the cache to 15 min., then tried rebooting the finder, repairing the apple tv, and lastly rebooting the apple tv, all from the DVD menu, with no luck. It looks like whenever I try to play from SMB it reboots the finder. Any suggestions?

As an additional test, I took a 2 GB flash drive, converted a chapter from a DVD using Mac the Ripper and put it on the drive. Then I plugged it into the apple TV. The drive and the file was recognized on the Apple TV, but nothing happened when I selected play title. It does play on XMBC, albeit choppy.


ATV Flash, did you make any significant SMB connection changes in the latest 3.3.5 release?

The reason why I asked is that I updated to 3.3.5, tried to connect again, and I was able to get a feed. Initially just audio, but with some cache adjustments, changing the setting back to enabling DVD menus, and a reboot or two, I seem to have made it work once. I still have some testing to do here to make sure I have shaken all of the bugs, but It looks like I can get the SMB share working.

I’m going to add some more media to see if I have any more trouble, and will offer my settings suggestions if desired by users.