Navi-x search function always freezes ATV2

Has anyone had much luck with the Navi-x search? Everytime I do a search it freezes up my ATV2 and I have to reset. Other than search it plays videos fine.

What version of XBMC are you running?

If your using the out of the box version included with fireCore beta5 you might consider the Nightly builds? I don’t have any issues with the search in Navi-X running the latest 10.0-9 release…

XBMC nightly .deb builds

I was running the latest nightly that I obtained a couple of days ago from http://hadm.net/xbmc/latest_atv2.deb. I uninstalled it and then reinstalled xbmc through NitoTV (10.0-9)which as it turns out is newer than the nightly that I had(10.0-7). It seems that the freezing on search is not as bad with 10.0-9 but still happens sometimes when I click to search navi-x extreme or megavideo. I will try your link and reinstall navi-x as well to see if it helps. Thanks

OK I have tried keiths latest build (June 18th I think) as well as official 10.0-9 build with no change. I am running navi-x 3.6. Here is what is happening:

  1. I open Navi-x

  2. I click on the first choice in the list: navi-x media portal

  3. I click the search icon (second one to the right)

  4. I click on search navi-x (top of the list), or even search megavideo

  5. search box comes up and I click new search

  6. Nothing happens after box goes away (keypad to type search does not come up and screen is frozen)

I have tried uninstalling/reinstalling navi-x multiple times as well as xbmc with no change. Is anyone else having this issue, and if not what versions of xbmc/navi-x are you running? Thank you for any help.

having the same problem… dont know what going on any help will do…

Hey Folks. This is Bill Daly with Team Navi-X. This issue has appeared as of recently and appears to have something to do with XBMC’s latest builds with Navi-X 3.6. It seems someone has changed the python library in 11.0 and then back to the old python libs in 11.1 from what I understand. If you would like to see what combinations people are reporting that work, check out http://navix.turner3d.net/forums    I don’t have an AppleTV or I could quote back the revision numbers for you, but you can keep track of this issue at our forums. Thanks.   Bill Daly, a.k.a. iRoNBiLL Project Coordinator for Navi-X

I have found that version 3.5.4 works well with ATV2

How do I get the 3.5.4? How do I downgrade from 3.6? Thanks!

First remove navi-x. Upload this one to the atv2 and install from the ad on menu.

http://code.google.com/p/navi-x/downloads/detail?name=Navi-X_v35_4.zip&can=2&q=

 

First remove navi-x. Upload this one to the atv2 and install from the ad on menu.

http://code.google.com/p/navi-x/downloads/detail?name=Navi-X_v35_4.zip&can=2&q=

Navi-x will let you upgrade/downgraded within the navi-x menu. Just select the version you want then restart navi-x.

http://code.google.com/p/navi-x/downloads/list

Or you can manually download it here.

iRoNBiLL

Thank You Both!!!

If someone wants to try using 3.7, I have been told the commands for login and search boxes were changed to XBMC standard input boxes, so this issue should be resolved now. If someone could test out 3.7 on XBMC and check search and login box’s, that would be great. Trapped at work so I can’t do it as usual. Thanks.

iRoNBiLL

 

Hi iRoNBill , I use Navix 3.7 on XBMC 10.0-9 on AppleTV2. I WAS experiencing a freeze in Navix after I search navi-xtreme for “rambo” …got hits, then clicked back and searched for “ganster” , which gets no  hits and the entire appletv2 just freezes.

I did these exact steps on another similarly configured appletv2 box and it did exactly the same. Froze perfectly.

However I rebooted and tried the exact search order above but it did not freeze! and since then I can’t seem to recreate the problem…but I’ll keep trying.

When I use NAVI-X I get buffering issues.  Any way to fix the buffering so that XBMC and NAVI-X can pre-buffer like 50% of the movie, then in the background buffer the remainder.  Or during the next buffering pause, buffer the remaining 50%?

I am somewhat surprised that the buffering is not automatically adjusted to grab at least 50%, with some timer telling you how long it will take at the transfer data rate, before the 50% will be reached.  In the ICEFILMS plugin we get that timer pause while megavideo awaits its timer for access, because it is a free source on megavideo, not a member login.  Would be nice of NAVI-X did something similar.

 

 

Hey WagesofSin…are you still having good luck with navi-x 3.7? I had a couple of freezes so I went back to 3.5.4.

looks like the buffering issue was the source.  If I change sources I get no buffering issues.  But I do get Navi-x locking up the ATV2.  even though I downgraded to 3.5.4 version from the 3.7 version.  

 

In general NAVI-X seems to beat ICEFILMS as a source for content to watch that is streaming.

Hi 3.7 definately still freezes the ATV2 but very randomly, I can not replicate it. Moving to 3.5.4 does not help the condition is the same.

Obviously outside my scope I can only hope the powers at be will one day fix this. Still Navix rocks.

By the way, it’s been determined that this will have to get fixed by us in an update. I will announce when the update should address the issue. Sorry for the confusion folks but it looks like Python 2.4 brought in a few changes that breaks functionality. Make sure you try old XBMC versions with older Navi-X versions and newer with newer to know for sure. Thanks.

iRoNBiLL