My story: Getting Chrystal HD ( BCM70015) to work on my Silver Apple TV, gen 1 (atv1)


1.). "Allow hardware Acceleration (Chrystal HD) " does not show up in Video/Playback. -- So you have install your card and  have loaded the driver via "intoTV" but, when you go to turn on the driver to enable the Chrystal HD the "Allow hardware Acceleration (Chrystal HD) " is missing. I found that if you use the power icon button on the bottom of the XBMC window and use the "reboot" option this will kick start the driver and Chrystal HD to work. Note, the reboot will take a little bit of time to shutdown and reboot. (the first couple of times I thought the system froze). When the atv1 finally restarts the apple will pop up and you will get the atv1 start up movie. Now if the start up movie looks bad, bad Pixels and crapy screen flow. This is good because it is showing that the atv1 is being forced to use the Chrystal HD card. Also my system will have no sound during the rebooted startup. I am using the optical sound port. Now that the atv1 is back on, click your way back to the XBMC and launch XBMC ( I am using Eden). Go to: systems/video/playback/ and "Allow hardware Acceleration (Chrystal HD) " should be there.


2.). 1080p movie: stutters,  bad audio, start and stops. The remote: will not work or takes a long time to interact with stopping/pausing the movie. ---  There may be one or two or both issues here: The first on is probably the Chrystal HD is not loaded, I have found that even when the "Allow hardware Acceleration (Chrystal HD) " appears to be checked and active it is fact not active. I have found that rebooting through the XBMC power button works best. see issue #1.


3.).  I am still getting stuttering and audio hopping  with my 1080p but only now and then as the movie is playing. -- I found that FTP ing the file on to the atv1 hard drive solved this issue. The 1080p file are huge and I believe that the transfer needs to be as short as possible. I have tried media streaming, USB flash drives and USB hard drives and every time I get some stuttering and audio glitches. When I use the Cyberduck FTP and loaded the file on to the atv1 hard drive I get a perfect play back.


Additionally I disabled the 'Apple H.264' Located in Maintenance/Settings.


The last movie I played was 9GB and a .mkv