My Experience with Seas0n Pass on ATV2

Tonight, I successfully got the Seas0n Pass installed on my brand new ATV2. But that was after 7 different tries during today and 6 restores by Apple iTunes. Running on a native Mac OSX 10.7.2 (Lion) with the most recent version of iTunes (10), and the most recent version of Skype, and with the security features disabled (default), I still had issues. I had already disconnected all my USB and Firewire devices. I had closed most of my programs: Pages, Numbers, BusyCal, Parallels, Safari, Address Book, and iTunes. But I left running Skype, Dropbox, Transmit (menu), Sound Source, Boom, TotalFinder, and Growl: all auto-start applications that have an icon in the menu bar. Every single time I tried to install the firmware using iTunes, it would fail on the “Verifying Apple TV with Apple” part and then I’d get some code. As I started closing applications, I finally ended up with just Skype, Firefox, and the background applications. Each installation failed with some code.

 

Then I found out that I was using an older version of the IPSW file and that a new Seas0nPass was released, by coincidence, today! Another two rounds of failures. So I started doing more troubleshooting. And here’s something very interesting I found:

  1. When I ran Tiny Umbrella, the program cautioned me that running Skype would cause problems with Cydia. So I closed Skype. I didn't think it would cause problems with Seas0nPass but hey, after six tries, it was worth trying this. I made sure that Cydia (or whatever it's called) was not enabled when I closed Tiny Umbrella.
  2. When I started iTunes, I was asked to sign-in which I had always done in the past. But for some reason, I didn't do it this time.

And it just worked. Everything installed without issue and without requiring the need to tether, either.

 

So, I’ve got the full packages installed and everything’s running like a charm.

 

BTW, the instructions say that you must use ONLY the silver remote, not the white remote to reset the Apple TV. But Apple says that if you use the white remote (my wife’s favorite remote), you can press the large middle button and then press the down portion of the outer ring and it’ll do the same thing as pressing Menu+Play/Pause on the silver remote. I didn’t try it but it’s worth looking into.