MultiTrack above 5.1 play in stereo on inFuse and Apple TV 4K

Hey all: I’ve found a really strange problem with Infuse and multitrack audio above 5.1

I’ve upgraded to a much more capable sound bar that can integrate perfectly into my 4K setup. I’ve tried infuse and Apple TV 4K with the new setup. When playing a movie with a Dolby, or DTS 5.1 track, I get 5.1 PCM as expected. When I’ve tried movies such as the Blu-ray copies of Star Wars that have DTS 6.1 tracks, I get only stereo. When trying the movie “Pixels” which has a TrueHD 7.1 with Atmos encoding, I also got stereo, until I manually re selected the audio track, then I got 5.1. However this didn’t work for the Star Wars movie with DTS 6.1

As a test, I played the same movie with 6.1 via my 4K Blu-Ray Player via DLNA, and the DTS track played in 5.1 and was correctly identified as DTS HD Master Audio, so the problem only seems to be with Infuse. I have all audio settings in the Apple TV settings and Infuse settings set to Auto for audio. From memory, I don’t recall this issue happening on the Apple TV HD, only the 4K, but I haven’t tried this movie on the HD only setup via Infuse to confirm.
I also remember this track being labeled with an ES as part of the codec name as well. Beyond this little glitch, everything seems to be working. All movies are ripped as MKV with MakeMKV at full quality, so what Infuse, or other streamers get is the full quality movie as it would be on disc. Only the container is changed from .m2ts to MKV, everything else inside, is the same.

How many audio tracks are you including in your mkv? Just the one lossless or others? Is it perhaps just selecting the wrong track by default?

The MKV files are identical to the m2ts files on the disc. I did double check this, and that’s not the issue, as manually changing tracks, and then switching back still gives stereo. For example, I changed to a lossy 5.1 track, and got 5.1, put it back to the lossless 6.1 track, and it went back to stereo.

Hey all, I’m coming back to this post to report more findings. It seems like, even if the track is labeled (Default) infuse has trouble playing surround with 6.1, and 7.1 tracks. What I experienced this time on Jurassic World: Fallen Kingdom is, the correct DTS HD MA 7.1 track is selected automatically, but plays stereo, until I change to a normal DTS 5.1 track and back to the 7.1. On the Star Wars movie, the track cycling didn’t produce surround upon the 6.1 track re-selection. It did however produce surround on the 7.1 track in Jurassic World, and the TrueHD 7.1 track in Pixels. Because the new sound bar the Apple TV is connected to supports Atmos, and DTS:X, I wonder if that’s causing problems for the Apple TV running Infuse because it can’t bitstream, and is sending LPCM.

I’m wondering this because on devices that send the audio by bitstream always play correctly. Even Plex on Roku works because Dolby TrueHD is just play as Dolby digital 5.1 and DTS HD MA is played as standard DTS 5.1 since the Roku doesn’t support passthrough of the lossless codecs. I have not noticed the issue with Infuse running on my Apple TV HD which is connected to an older model sound bar that doesn’t support 3D, or lossless audio, only lossy 5.1 or PCM 5.1. Infuse seems to be the only glitchy app in the 4K setup, iTunes movies play Atmos on supported titles as the Sound bar reports it as Dolby MAT, and that goes for Atmos encoded Music too on Apple Music.

I have also noticed that the Infuse updates have slacked off too. For a while there, I was getting frequent updates. I have also checked both sets of Audio preferences in Infuse, and the System settings, all settings required to be set to Auto, are so. I am running TVOS 15.2 on both devices, and the lates available Infuse 7 Pro. I just checked the App Store today, and it said I had the lates.

Thanks for any further feedback anyone is able to give.