MovieDB selection errors

This is something I notice with a few movies. The wrong movie is chosen!.. From the filename I would think it was obviously the 2019 version, yet I have to go edit metadata to select the correct one as Infuse thinks it is the 2017 one.

On the actual video file does the name have the parentheses around the year? If so, as a test could you delete the parentheses and then try the edit again to see if that changes the order of suggestions?

Unfortunately not. With the file explicitly renamed as ‘Monster Island (2019)’ it still finds nothing.

With the latest Pet Sematary, also from 2019, the old one is chosen

Sometimes I just look for a suitable Alternative Title in TMDB to cheat these mishaps. In this case I think that Monster.Island.Kampf.der.Giganten.2019.mkv should work.

When I’ve done this with other films, it still displays the English title in Infuse. So it’s kind of a win/win.

Maybe give that a try. :slight_smile:

To me the point is that I give the year, I give the correct title, it shouldn’t select the other one…

I simply click on edit metadata when I see an error and repair it, easier than trying out a bunch of names

1 Like

I’m checking on something, it may be TMDB that has a problem. Will keep you posted. :wink:

I agree right up until, for any reason, Infuse does a fresh metadata scrape - which does happen.

As long as you have iCloud sync enabled it should restore the corrections too.

I have iCloud turned on, lol

I figured you probably did, :+1: just in case someone new reading the thread wasn’t aware that the iCloud sync will recover corrections if you get the dreaded cleared memory message on their device.

The following files are in a directory called LEGO DC Comics Super Heroes:

  • LEGO DC Comics Super Heroes - Justice League - Gotham City Breakout (2016).mp4
  • LEGO DC Comics Super Heroes - The Flash (2018).mp4
  • LEGO DC Comics Super Heroes Aquaman - Rage Of Atlantis (2018).mp4
  • Lego DC Comics Super Heroes Justice League Vs. Bizarro League (2015).mp4
  • Lego DC Super Heroes Justice League - Attack Of The Legion Of Doom! (2015).mp4

All of these files are identified as “Lego Star Wars Terrifying Tales” …

Why? Apart from the word Lego, it has nothing in common.

You need to delete the “Lego DC Comics Super Heroes” from the file name, seems that’s not actually part of the movie name itself. I tried your way and got the exact same results as you but when I just deleted that part in each of the file names it all pulled correctly. (also I deleted the parenthesis and the exclamation point in one of the names. Those can cause problems sometimes.)
Lego Names for Frankjec

Further to what NC_B has said - I had the same issue, for some reason it’s sensitive to the “DC” part. So if you want them all stacked in the same place without dropping them into a folder then you can just drop the DC and name them as below, that worked for me.

LEGO.Comics.Super.Heroes.Aquaman.Rage.of.Atlantis.2018.mp4
LEGO.Comics.Super.Heroes.Justice.League.Attack.of.the.Legion.of.Doom.2015.mp4
LEGO.Comics.Super.Heroes.Justice.League.Gotham.City.Breakout.2016.mp4
LEGO.Comics.Super.Heroes.Justice.League.vs.Bizarro.League.2015.mp4
LEGO.Comics.Super.Heroes.The.Flash.2018.mp4

I renamed them, and the other Lego directories as well (Scooby Doo, Super Hero Girls, Star Wars). I’ll report back

I went for NC’s solution as I don’t like all the periods in between, though I am sure that will work as well. In fact I left the year in parentheses and it still works.

But still I would like to know how Infuse gets the idea to use that metadata as Star Wars and DC have nothing in common…

1 Like

It’s not really Infuse that’s making the decision, Infuse uses the API from TMDB and there’s where the magic behind the curtain happens. I’ve just accepted the fact that occasionally there has to be a bit of voodoo done to make it happy. LOL The parentheses are usually no problem but the exclamation point has caused some issues more often.

Glad you got it running like you want it! :+1:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.