Movie Poster Art ignored on ATV

Since one or two versions Infuse on Apple TV does not read my custom Movie Posters anymore, on Mac, iPhone, iPad it works fine.
ATV is loading default ones, i never changed settings. That occured out of nothing.
any suggestions? Restarting does not fix it.
They are named exactly as the movie files, like always.

Is this happening on all movies or only some?

Are your jpg files in the same directory as the video file or do you have your movies in individual folders/directories with the jpg in the same directory as the folder containing the movie video file?

Hi Bullseye, its very strange behavior.
it happens not to all of my movies, one movie i added recently did not update on my ATV, even after restarting everything multiple times. Now the more strage part, after i watched the movie, the poster got an update to my version?!

my library is build like that, the black dot is the folder. Every movie has its own folder.
It always worked for me just fine like that. All Devices work fine currently with everything up to date, except the ATV. some movies just don’t update.
Also i recognized if i add an poster art, it marks the movie as recently added. Is that on purpose?? i would not expect to work like that.

  • Cloverfield (2008)

    • Cloverfield (2008).mkv

    • Cloverfield (2008).jpg

    • Cloverfield (2008).de.forced

Infuse has changed where it doesn’t constantly do media refreshes like it used to due to the massive amounts of usually needless traffic since the files aren’t even being browsed. If you navigate to the folder that the movie is in it should update the poster fairly quickly (within 15 to 30 seconds from my experiences) and I think that if you do a “refresh metadata” from the library it will pick up newly added artwork.

Infuse will scan for changes also when you’re browsing the shares so that is why you’re seeing posters change.

It takes a while ( for me it was a few weeks) for Infuse to scan through everything now that it does it in chunks instead of the scorched earth method of doing everything everytime you run it.

Now I rarely notice any changing posters unless I want to update it myself.

Give it a while to settle in and it should be good.

i gave it a short try to klick the folder which is something i never did on my ATV tbh.
i always search via library. For the last movie it worked! I will check that solution out in details if it solves the problem for me. Thanks for that tip!