Movie metadata source


Actualy all of my movies went to the other category. Anyway I figured out, that I don’t use the Library view, but go for my Remote NAS “view”, where all the files shared to ATV are visible. I would accept it, but it caused the next problem: Even if I setup to see my files regarding their names, first I can see the list of my tv shows in alphabetical order and only then my movies. It seems there are two categories within the same list. First tv shows, then movies, ok it is not so nice, but I could live with it. Here comes the tricky part: between the TV shows there are some movies as well. The reason could be, that those movies are spilt up in two for example, especially older movies (like movietitle part 1 and movietitle part 2), or if there is a subfolder within the movie’s folder( like I have some movies where the audio of a given language is in a different folder) it also belongs to this part of the list. It means the second part of the list contains only movies with only one movie file within its folder, if there are two parts or there is another folder, media player deals with it as a kind of TV show (even if you set it up manually pressing the button on the remote, then choose movie, etc), so it is a bit annoying, I dont see, why the files are not simply in alphabetical order regardless of their content, if there is an option exclusively for this.


I don’t know if I was clear enough, it is a bit tricky to explain.

I actually think the cause is something slightly different to the movie/TV distinction!

What I believe you are seeing is the case that folders with more than one file in them are shown before all files that are not in folders or folders with a single file.   I would like an option where all folders and files follow alphabetical order with folders mixed in with files where necessary.

Lately my metadata fetching has gone in the toilet. What has changed? Movies that have periods between word NEVER work and movies (like Top Gun) which has worded forever, suddenly no longer works. It’s spelled “Top Gun (1986)”. I don’t want to have to go and rename all of my files that have worked perfectly for years. What’s up?

Same here - All of the sudden I have movies that don’t show up anymore and movies that use to be found like "Public Enemies (2009) show up wrong. There are two on TMDB one is a superman and batman comic and the other is Johnny Depp. The JD does not show up even when I try to reload the metadata.

It seems this is related to an minor API change at TheMovieDB. In short, if your filenames have the year in them then it’s likely to fetch the wrong info, at least in the current version.

We’re working on a fix to address this change, and should have an update out shortly.

Awesome! thanks James.

Great to hear! (I just lost all my metadata trying to troubleshoot this problem.)

Will this fix be made available as a free update to Mediaplayer? (My aTV Flash subscription has expired, and the product I paid for little over a year ago will be useless without this fix…)

When your subscription runs out you can still install updates via the Maintainence menu on the ATV … So you should be OK to pick up the fix when it is available.

What you cannot do if you don’t have a valid subscription is to run the ATV Flash Black installer from a PC/Mac - so this prevents you re-installing if you re-jailbreak your ATV for any reason.

+1 This is correct.

Just recently i changed from a external HD to a NAS to store all my movies. I had to setup completely new. After i have done that, fetching Metadata does not work anymore. What could be the problem?

Sounds like the same problem. As described above, the 3rd party API from used to annotate movies with metadata has changed, so if your filename has a year in it, it will fail.

@James: Metadata annotation is likely the single most important feature of your product. Do you have an ETA for a fix? And will such a fix ensure that aTV Flash will continue show to the best match in the results returned from based on release year if such a 4-digit number exists in the filename?

This is a really weird bug because we have three ATV with all the same software and jailbreak, but each of them is showing different files in the Library. They are all connected to the same source so that should not be te problem. For example the ATV in my bedroom is showing only “Still Bill (2009)” in ‘Others’ where the ATV in the livingroom is showing “Gangster Squad (2013)” “Amour (2012)” and few others in ‘Other’ in the library…


Hope this will be fixed soon.

Just in regards to a post by rndrummond on the first page, that tip about removing the date on a title if it’s not working helped me a lot.

I had “40 Year Old Virgin (2005).avi”, and it just showed a still from the movie as the poster. Removed the date and it loaded perfectly. 

I assume you meant that you removed the year and parenthesis.

Sorry.  Yeah. Year in the paranthesis removed.


“40 Year Old Virgin (2005).avi” was changed to “40 Year Old Virgin.avi”.

Hello James, how long will it take until the metadata search will work again? It’s really a horror without correct metadata



We’re hoping to have it out next week. Unfortunately it’s taking a bit longer than usual.

A bit more info can be found here:

Thanks a lot for your answer, James,


what I discovered yesterday was that there are also some problems in PLEX with the metadata. It helps a lot to remove the year in the title - doing so I solved about 90% of the wrong metadata issues.



Any news on the progress of this fix?

Also, will this fix extract the year from the title if such exists and use it to pick the right metadata, or is you fix simply to strip the year? If the latter is the case, I am considering removing years from my entire library, just to make it work reasonably until your fix is released.

Please advise…

The fix should be out within the next few days, and it will properly handle the year (if present) in the filename.

Hang in there. ;)