Movie data not appearing

  Hi,

I have just installed MiRow and had it working well with most of my 
collection. Most movies and TV shows were listed properly with the poster art 
etc. My media is on a NAS drive and I had is mounted to set it up. I went to 
launch MiRow and went into the Media/Movies directory and there was nothing 
listed there even though all the media had been there listed by Genre 
Director etc. This time there was only scan for files. I checked TV Shows and 
the same thing.
The NAS drive was mounted so I rebooted and wen to the Movies and the TV 
Shows and deleted the meta data. I then started over again and went back to 
Import all Data then settings/fetch movie data and populate data. The TV 
Shows most were back just fine. However the Movies there is just All Movies, 
I go into there and there are only 9 movies all with the file name Access 
Denied. There is no descriptions for the movies however the cover art is 
still there. There are no other movies. I have re-imported and rescanned 
several times and get the same results, only the 9 movie files where 
thousands were before with All the data. I have checked and there is no issue 
with file access to the movies, they are on the same NAS as the TV Shows 
which are for the most part OK.
 

I have since installed MiRow on a second Mac, a Mac Mini Intel 1.83 ghz and am getting the exact same problem. The TV shows import no problem with all the show descriptions and art (all but one TV series don't know why yet) but the movie directory only shows 9 movie files all again with the name "Access Denied". There is no other associated data with these files either. I have checked file permissions of the NAS and they appear fine. If it were file permissions on the NAS this should effect the TV Shows too because they are stored in the same location. I even copied some movie files to the local ~Movies folder and tried to import these only. The import finished and said that it imported 2 of 2 files and when I went to the MediaMovies there was nothing there. This was done on the clean install of MiRow.

 

The only other thing that I can suggest is that there is an issue with the IMDB scraper. It is the only thing left in the equation as the TV Rage scraper seems to work fine other than the one series that it missed repeatedly.

Any help on this would be appreciated.

 

 I have basically the same issues as the other poster here.  

I have all my AVI movies on an external hard drive. I try getting movie covers and your MiRow app scans forever and doesnt find anything. The most 
recent to Remote Helper, increased the ability to tell it to scan for movie 
files, to see the cover flow, but it never gets there.

My movies are located in /Volumes/Verbatim/Amov 
I actually even renamed the folder with an A in front hoping it would find it 
and start attaching movie covers, but it hasnt, For some reason the MiRow 
app always wants to scan my main computer even though I have next to no 
movies there.  My external drive is filled with Time Machine backups and piles of stuff I dont want MiRow to search through.

I tell it to refetch movie data and off it goes re-scanning my computer 
instead of the specified folder. Its odd because it knows thats my movie 
folder, but it never seems to get there.  The USB drive humms and I assume its looking, but again, no status bar movement and no movie covers pulled from the web.

I'm enjoying the streaming of the movies. My only issue with Remote Helper, 
is you can get caught in some screens that dont bring you back easily to the 
leather control and menu section. At points you basically have to exit the 
app and restart it to get to the selection screen.

Also for the iphone, it displays a mini movie but no sound. I was thinking 
the iphone app should have sound as well so you could walk into another room 
and still not miss the show.

I think your app holds lots of promise, if you can get a few issues ironed 

 

 Just wanted to add that I did download a trial of DVDpedia, could this be part of the problem?

I'm enjoying the MiRow player, it also plays my music well so ita nice to have an all encompassing app.  Looking forward to trying Netflix, but my collection of movies doesnt have coverflow, or labels.  Once this gets cleared up, it will look polished.

Exactly the same problem here. I had an "access denied" on all my movie title. I tried to reimport them, without success. MiRow now just recognise the TV Shows, none of the movies, whatever I try...

 HI I started this thread and wanted to post a followup.

I am glad to see that I am not the only one getting the Access Denied name for movies.

I thought I would perform another test to try to rule out the issue being my NAS. I loaded a bunch of movies onto my Macbook Pro 2.8 ghz Intell core 2 Duo with 10.6.4. Installed MiRow and did the import. All the movie and TV show data appeared as it should with all the meta data. I then went to the Movies selection and hit the right arrow to bring up the menu, I selected "reset import decisions" then "clear metadata" I then went back and imported again and sure enough when I went back into movies all the metadata was gone and all the movie file names were "Access Denied" for movies only. Any attempts to re-import to get the metadata back have failed.

I am hoping that this issue can be resolved quickly because when this was working properly it was working very well.

DVDpedia has been known to have a few issues with MiRow. If you're not using it your best option may be to remove it.

If the DVDpedia Front Row (DVDpedia.frappliance) plugin has been installed you can remove it as well by following the steps here: support.firecore.com/entries/304606-removing-plugins

 

This seems it may be an internal issue with the IMDb. It seems to be resolved now as things are working ok on this end.

Your best option may be to remove the Sapphire database file and star fresh. This can be done by navigating to the ‘~/Library/Application Support/Sapphire’ folder and remove the ‘metaData.sapphireDataV3’ file located there.

 OK I removed the ~/Library/Application Support/Sapphire' folder and remove the 'metaData.sapphireDataV3' file 

Scanning again.

It seems to be again off scanning a pile of folders it doesnt need to be going down and I cant seem to prevent the MiRow app from heading there.  Pulled the itunes folder to search and thats about the only other option.

 

I guess my question is, are there another 3rd party app that would gather the proper meta file and cover flow data for my movies, that I could use rather then having to run such a long dreadful scan in MiRow?

I like the player aspect of MiRow, Saphire remembers if I have watched something or not.

Removing the database file was the first thing I did but the problem still remains. No movies in the movie directory, TV shows are fine.

I'm not using DVDpedia or others plugins. Really annoying.

You can have Sapphire ignore specific folders.  There is a guide that describes this in more detail here: support.firecore.com/entries/304602-accessing-non-itunes-media Scroll down to the 'choose which files to import' heading.

 I figured out that the movies were bringing up lists based on the name of the external hard drive and the folder name the movies were in.

So I names my external hard drive "/"

and my movie folder "/"

Now when it finds a movie its lists things like 11:14 because the drives are listed as /:/: stuff like that.

Basically until the IMDB scraper can't seem to ignore the file name of your hard drive, the /Volumes/External Hard drive name/Folder of movies/

Until the app is written to ignore the path names, the IMDB database will never get a good list.

Still the software is improving.  Yesterday was the first day it was finding a movie and calling up a imdb list.  While its not working right its an improvement.  Also the iphone app does have more options when selecting the right arrow to ignore folders.  When you do want to scan, it now doesnt need to scan my whole computer, a massive improvement.  Also I can finally tell it to ignore my other files included in my drive.

So the MiRow Saphire app is zooming in much better, just need to get it to ignore the /Volumes/External Hard drive name/Folder of movies/

 Yes max I can now ignore folders and the scanning has been vastly improved time wise.  Just need to get the IMDB scraping the right info to match movies with covers.

You may check to ensure the' Use Directory Lookup' option is unchecked in the Media --> Settings menu.  This should help with skipping over folder/drive names.

 Thanks max!  That was the ticket, its working and pulling up movie covers now.  MiRow is certainly starting to work well.  Just finished going through my library, IMDB database worked very well finding most movies.  Now my collection looks professional and they stream from the drive.  

 Just wanted to thank the Firecore staff, I started this thread about the Movie info not appearing and the file names all being Access Denied. Iw was in fact IMDB,, it now works like a charm, problem resolved.

 

Thanks Again

Dave