Mounting specific volume path from Airport Extreme drive

From ATV, I am trying to access (and then stream from) a folder from my Airport Extreme connected hard drive using SMB. I have no problem doing that when mounting the root directory of the drive itself using the custom mount option in nitoTV. I simply fill in the applicable fields and specify in the volume path option: Backup Drive (which is the name - case sensitive - of my external USB drive connected to the Airport Extreme). I then go into whichever ATV option I wish to use to stream my video and choose “Backup Drive”, as that shows up in the list of media locations or mount lists. My problem is that since this is a 1.5 Tb drive, it is being used for general file backups as well as storing my DVD and other video files. When I choose the “Backup Drive” mount, I have to drill down further to the actual folders that my video is in - which in my case is: Backup Drive/Itunes/Movies. It’s not too big a deal to have to manually go into a few other folders to find my movies, but the real problem is when I use Sapphire. When I ask it to fetch movie data for adding info and graphics to all my movies, it scans the entire hard drive for movies, which means it also scans through thousands of other non-movie files that are on the drive as well, because I can only specify the root directory and not the “Movie” directory specifically. From the volume path field, I have tried to specify the path: Backup Drive/Itunes/Movies, but the mounts still show as “Backup Drive” and I still have to go deeper to the folder I want. I have tried the custom path option and that does not seem to make any difference. Through playing around with those two options, I have gotten directories other than “Backup Drive” to show up, such as one listed as, “Itunes”, but when you click on them they either don’t do anything or show as an empty directory. They do not have the eject icon to the left of the name like the actual mount name of “Backup Drive” does, so it appears that they don’t reference the mounted drive itself, but maybe it’s a alias of sorts.

So, something isn’t right. Has anyone gotten this to work? Can someone tell me exactly how the lines should appear in the volume path field(s)? Is my syntax wrong? Does the path need to include more info such as volume/user/???,etc. Do I use both volume path and custom path, or is custom path just for when you access via AFP? The following from an AwkwardTV document is what I tried to use to help me, but so far to no avail. Any help would be appreciated. :slight_smile:

Volume path: This is the name of the volume path you are attempting to mount, for each protocol this may be a bit different. For afp (unless you have custom
shares setup outside of the standard File Sharing preferences) you will ONLY be able to mount your root volumes or your user volume. If you want to link
deeper into your volume turn on “Custom Paths” (discussed below). For nfs and smb you may have to put in full paths to the mountable volume (ie
users/thatname/movies)

Auto Mount: whether or not the mount point will mount at startup (NOTE: mounts have a 15 second delay upon startup, the moment startup occurs
networking isn’t immediately available so we need to put in a delay before attempting to make network connections, in addition for SMB mounts to
work in automount you MUST have a proper rc.local setup with the smbfs.kext getting loaded at startup for this to work)

Use Custom Path: This will toggle on or off a custom path to be linked into your mount location (where “Files” browses)

Custom Path: Only used if the above option (Use Custom Path) is toggled on. This is a nice workaround to afp limitations of only being able to mount root or
user volumes. The path chosen here will be appended to the “Volume Path” and will be linked into your mountLocation. (ie Volume Path = Macintosh HD and
Custom Path = Users/myname/Movies/MyMedia will link Macintosh HD/Users/myname/Movies/MyMedia into your mountLocation)

Is there a solution to this? I am having the same problem with sapphire. I want to connect to a specific folder within my HD. Eg. Media>Movies or Media>TV Shows.

Like the above post, I use my HD to store other backups so when it's importing data it's going through hundreds of gb's of unrelated material.

 

Yes, the solution would be to add a 'custom path' to the share point settings. This will mount the main drive, as well as a shortcut to a folder located on the drive.

More details on setting up network shares can be seen here.

That would be great, except that using the 'custom path' has no effect whatsoever. I turned custom path on and added the case sensitive name of the folder and it still mounts the root

The root will still be mounted, but you will have an additional shortcut to the custom path specified.

I am having an issue when over smb its not seeing any of my drives

I have the Mount address as the IP Address

Req Authen is yes

user and password is correct

Volume path is the Share folder of the IP

and it says the folder is empty

I can not get my drive thats connected to my APE to mount on my ATV1 no matter what I try?? Ay tips or tricks