mount_smbfs tree connect phase failed syserr = no such file or directory

 

I’ve got a AppleTv (1st Gen) and I’m trying to create a network share to access my 6TB RAID external harddrive connected to my iMac computer. I’ve had it connected and functional previously, since moved and now trying to recreate the network share again.

-The first time, I created the network share and tried to mount it, I rcvd the following error:

mount_smbfs negotiate phase failed syserr = connection refused

I found (and followed) the following Support Forum Post from Sunday December 5th, 2010:

I think I’ve found a way to workaround this problem. At least, it worked for me. The bad news is that you’ll need to completely recreate your SMB shares, but at least you’ll be able to recreate them and they’ll start working again:

  1. Connect to the AppleTV via FTP (http://support.firecore.com/entries/259290-transferring-files-via-ftp)
  2. Navigate to the Library/Application Support/nito/ directory.
  3. Copy the 'mounts.plist' file to your computer (for backup purposes)
  4. Remove/delete the 'mounts.plist' file from the AppleTV (WARNING! You will lose all of your saved shares).
  5. Restart the AppleTV
  6. Navigate to NitoTV/Network
  7. Recreate the SMB shares you require, as described in the ATV tutorials.

ADVANCED TECHNIQUES: If you are having problems with only one share, even after attempting to edit it in ATV, it’s possible to edit or delete a single entry from the mounts.plist file that you saved earlier, and then send the updated file via FTP to the AppleTV. If there is interest, I can post a step-by-step procedure, but this is not something for the inexperienced.

 

Now when I try to mount the Network Share, I receive this error:

mount_smbfs tree connect phase failed syserr = no such file or directory

Can anyone offer any suggestions / comments / ideas?

Thanks.