MKV Title metadata instead of filenames, even when 'show filename' is ON, and 'embedded Metadata' is OFF (iOS & AppleTV)

When using Infuse in list mode with MKV files, there is no way to display the FILENAME, it will only use the MKV metadata “Title” which is nearly always incorrect, and is UNCHANGEABLE without a transcode.

I have tried all the settings to override this behaviour, for example “show filenames” which does not override MKV metadata “Title”, it seems to always default to MKV metadata “Title” NOT filename.

Can you please confirm this ? And if possible allow Filenames to override MKV metadata “Title”

To clarify, I am not fetching metadata, I’m using local files only.

Thank you

Turn off “embedded metadata”.

Embedded metadata is off. I also switch it on and off again to see if it updated, it did not work. It still reads the MKV “title” in the metadata as the filename

Well, it shouldn’t be doing that if told not to look at the embedded metadata … odd.

Did you try disconnecting from iTunes sync, deleting the entire metadata database, and reimporting?

Since you do not have Infuse search for metadata (via TMDB), are you including local metadata (.nfo files) alongside your local content so Infuse knows how to identify it?

You say these are local files only. Do they match to something on TMDb or are they from your own personal library, like home videos? I believe that infuse if it can’t match from local files or TMDb it will look at the mkv title tag for matching.

You can use Mkvtoolnix to change the tag without having to reencode the files. It can do a quick header edit.

1 Like

I don’t use iTunes sync. This is an Apple TV streaming off Windows 10.
I don’t want to use any metadata, only the filename… that should be simple right ?

That makes sense, since even though I have “use metadata” switch offf, if I hold click on an mkv, and click “edit metadata”, then it states “-None - use embedded metadata”.
So even though use metadata is off in settings, it defaults to using metadata if there is no metadata. Which it should not be doing.

Fyi Clear all metadata did nothing to fix this

I think you need to either use local metadata (matched .nfo files), scraped metadata (via TMDB), or strip all embedded metadata from your files as suggested by @munpip214 .

Regardless, your actual filenames will always be visible at the bottom of the details pages (on tvOS).

That’s not mandatory, that’s an option. If you click “use embedded metadata” that will override your menu settings choice for that title.

The whole point of having a no metadata setting AND a use filename setting would be to override all metadata and use the filename right ?

Are you seeing any difference with Show Filenames ON or OFF? Can you post a picture of what you are seeing?

What type of streaming connection do you have set up? With some connections (like UPnP or DLNA) Infuse may not be able to see the actual filename, but instead get a file title from the server.

Are the filenames visible if you browse via the Settings > Add Files menu (iOS/macOS) or Settings > Shares menu (Apple TV)?

@james Filenames ON/OFF does not seem to do anything (iOS and Apple TV)
I’m using DLNA to Windows 10
Infuse seems to see most filenames fine (ie. not metadata)
Browsing via settings shows the same as what I see elsewhere, most filenames are ok, mkv and some mp4 are metadata title.
It does seem to be a problem with MP4 files as well as MKV. It looks like Infuse will always default to metadata title over filename, no matter what the settings are.

This may be your problem.

You may want to try setting up a SMB connection instead of the DLNA and then make sure the above mentioned settings (fetching metadata, embedded off, show filenames on, etc)

1 Like