MKV file defaults to commentary track

I have some MKV files where there is a Commentary track. On the iOS app (the problem exists in Infuse for both iOS and tvOS, but tvOS screenshots are a pain) the audio track selection looks like this:

Infuse always defaults to playing the Commentary track. It should default to playing the normal audio track. It defaults to the Commentary track despite all of James’ suggestions in this thread:

  • I have English set as my default language in Infuse
  • The English track is better quality than the Commentary track (5.1 vs stereo)
  • I used MKVToolNix to enable both the Default and Forced flags on the English track
  • In both tvOS and iOS, the English track appears above the Commentary track in the audio track selection screen

None of my other media players (VLC, Plex, QuickTime) do this. I don’t want to remove the commentary tracks, but I will only listen to them once in a blue moon. Most of the time, I will want to listen to the English track. This is clearly a bug since every available piece of information in the file and in the Infuse app settings is indicates that the English track should come first, but when I hit play in Infuse, the Commentary track is the one that plays, every time.

Any chance this can be fixed in an upcoming release of Infuse?

Is this happening with all your files, or just a few?

If you are able to send in a sample it may help us track down what’s going on here.

Uploaded.

Happens to all my files where there is a commentary track.

Any update on this issue, James?

This is on our list to look into after the 5.7 update is released.

Thanks for your patience.

I’ve noticed this as well. I’ve double checked and even remuxed some of my MKVs for The Venture Bros. series to test and be sure. All the episodes with commentary track still play the commentary track by default even though the tracks were and have been remuxed again for testing as follows:

Main Track: English AAC 5.1 w/ “Default Track” enabled
Commentary Track: English AAC 2.0

The upcoming 5.7.3 version of Infuse will correctly honor the default flag for audio and subtile tracks. :slight_smile:

Awesome! I’d say you guys rock but I’m assuming you’re used to hearing that by now! ?

Thanks! ?

This issue has returned after the most recent update. It occurs on the AppleTV, iPhone, and iPad.

We’ll have a guide up soon regarding the new logic added in 5.7.4, but if you want Infuse to respect the Default flag you will want to ensure Settings > Language > Audio option is set to Auto.

This will cause Infuse to use the Default flag, if set. If no flag is present, it will use the language track which matches the language your device is set to.

Thanks for the reply, James.

My settings were set to Auto, but the commentary track was continually being defaulted to. I changed the setting to English and then back to Auto, and things are now working as they should. Again, thanks for the reply.

Great! :slight_smile:

@James: This is happening to me as well. Any file that has commentary is defaulting to it. I’ve tried the above and it had no effect. Would really be great if you had an explicit option to default to non-commentary tracks. I’m not sure why the default is commentary at all.

If there is anything else that needs to be set, or that can be set, to ensure that commentary is never the default, that’d be great.

Should clarify: Using on Apple TV 4K

If you have a chance, can you try running this video through MediaInfo and post the specs here?

https://mediaarea.net/en/MediaInfo

The new 5.9 update (just released today) will also show if a track is tagged as Default or Forced when viewing them through the Audio tab of the Playback Menu (swipe down while a video is playing).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.