Missing Show in Library List (and Search)

This technically affects both iOS and tvOS for me, though screenshots are from iOS because it was easier.

Basically my show Trailer Park Boys will not appear in the regular list. No idea why. Folder structure is there, and the meta data is even there. It’s found if I browse the folder directly and will show up under Watching. Seems to be doing everything properly but its not appearing under TV Shows, Movies or even Other. Just hidden from the regular list.

Folder structure is like this, e.g.
Trailer Park Boys > Season 1 > Trailer Park Boys S01E01 - Take Your Little Gun & Get Out of My Trailer Park.m4v

Is is possible that the share/favorite you have the files for this in is not checked in the library options? I had the same thing happen and the settings where you select which shares are included in the library view had been changed (fat fingers and old eyes to blame :wink: )

Unlikely, I only have a few folders shared with the vast majority of my shows. As far as I can tell this is the only one missing. Plus if the folder wasn’t included in library options it wouldn’t appear when browsing the share directly.

Actually you can have a favorite show a series with full metadata and not have it included in the library. I do that for shows I want to preview and not include in the library.

Just reviewed your pics again and it looks like you ARE getting the info in the Library and NOT getting the artwork in the file view.

How do you have the files organized on your server? It should be “Series>Season 01> season 01 files” and then each following season in it’s own folder under the series.

Also, just another possibility, in your original post you have your season folder named “Season 1” and the episode is showing S01E01. As an experiment could you change to folder to Season 01 instead of Season 1?

Maybe I’m confused then. Under Settings > Library I only have 3 shares, they are all checked, and contain everything. As far as I can see all shows from my TV share are there, with the exception of this one. Have I mistakenly hid it? I didn’t think you could manually hide an individual show.

Also the one photo is a bit misleading. This is not under Library > TV Shows, it’s under the Share directly. Those folders are the same folders on my local drive. Inside it is the grouped show that would normally appear in Library > TV Shows. See attachments.

The naming structure should be fine, it matches their standards and frankly works for every other series which has similar naming.

TV Shows / Trailer Park Boys / Season 1 / Trailer Park Boys S01E01 - Take Your Little Gun & Get Out of My Trailer Park.m4v
TV Shows / Trailer Park Boys / Season 1 / Trailer Park Boys S01E02 - F**k Community College Lets Get Drunk & Eat Chicken Fingers.m4v

I’ll try modifying the listing. Originally (and most of my shows) are TV Shows / Series Name / Season X / Episode 1 - Name.m4v. I changed it to S0XE0X because it wasn’t organizing them properly.

It might be that you have accidentally marked the Trailer Park Boys folder to use local metadata, which if missing will mean it will be missing from the library view.

Browse to the TV Shows folder and long press on the Trailer Park Boys folder … if it says “Use Local Metadata” then things are correct, but if it says “Use Online Metadata” you need to select it to switch it back to using the online metadata.

Another indication is if you are in the Trailer Park Boys folder and it says “Local Metadata” in the top right, then it means you are using local metadata.

Nope, not using local metadata. Checked it for the main folder and each season. I’ve also tried various changes to the folders, /Trailer Park Boys / Trailer Park Boys S0xE0x.m4v (all episodes and seasons in the root)

Try just changing the name of the Season folders on the server from Season 1 to Season 01 and so on for the rest of the seasons.

No go. Renamed them all and scanned it again. The changes show when browsing the Share directly. However still missing from Library views All TV Shows, All Movies or Other. Also it’s gathering the metadata correctly. Everything you see attached was gotten via Infuse fetching.

The first image is not in the library, it’s in the folder view since the folder is highlighted at the bottom. Try first tapping the Library icon which is the first one on the left, then above that you see movies, tv shows and other. Tap TV shows. Then tap the magnifying glass at the bottom. Then either enter a name in the search box under the word browse or select a category to look through. If you choose all TV shows you should be able to scroll through and tap on the Trailer Park series and see all the graphics. The highlighted icon on the bottom of the screen should stay the magnifying glass. Not the folder.

See if that makes any sense.

Also in the folder view instead of the Library view you wont get the season artwork. It’s been that way as far back as I can remember, don’t know why but in the folder view you don’t get season folder artwork. You get series poster and episode artwork but not the season folder art.

EDIT TO ADD: I don’t use the iOS version very often since I’m still in the stone ages with an original iPhone SE not the new fancy SE so I have to hunt and tap to figure things on on iOS. I’m primarily a tvOS user.

Yeah, I know it’s the Folder view. It’s the only place the show is visible. This is the issue that’s confusing the hell out of me. Below are the comparison shots of Library view, Folder view and Library search.

Also I use Infuse on tvOS almost exclusively. Just easier to show using the iOS app. Problems are identical on both devices. I was up all night messing with things before posting here.

I may need to find the palm to forehead emoji. The problem may be in the series name itself. If you look at this user guide Metadata 101 – Firecore and read the section about “Excluding folders and extras” I think what may be happening is the word “Trailer” is being seen by infuse as one of the “Don’t Include this folder in the library” words.

Hmm, definitely possible. Wonder if I can rename it without messing with metadata. The only other thing is I have Trailer Park Boys - The Animated Series and “Out of the Park” that both have the same folder name prefix. They show up. They’re not in the screenshots because I removed temporarily while testing.

I’ll change the folder name and see if it affects it. Annoying if so but kind of makes sense.

One thought to try, rename the show folderand episodes using Trailr to replace Trailer. That little misspelling with the missing “e” may be enough to fake it out and let you do an edit metadata to find the right one. Infuse would then remember that correction. I’d still rename the season folders just to maintain uniformity between the file title and the season folder.

Yep, that worked. Clever man you are, thanks! My OCD can sleep now.

Solution: You need to remove the word “Trailer” from the file name. The folder names didn’t matter in my case, however if the word “Trailer” appeared anywhere in the name it wasn’t shown in the list. That includes episode titles, e.g. “Take Your Little Gun & Get Out of My Trailer Park”. Remove this, fix metadata and you’re good.

I sure am glad that worked! I’m too dang old to have a lot of hair to pull out on things like this. It just took a bit of trying to remember what would cause a file to not be in the library and finally saw the light come on.

That’s defiantly a time where the “Find and Replace” command comes in handy! :wink: Now it can be Miller time…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.