Missing Maintenance app after updating to 2.5

Updated to 2.5 within Maintenance app but after it reset the Maintenance app is gone. Infuse is still there and working but not able to go back into Maintenance to update Infuse or anything else.

same here

I have now updated my ATV2 with season pass and re-installed aTV flash and all is working great.

Same here, I opened maintenance and update it and now the icon has gone, I am afraid to do a software update because I don’t know if I’m gonna loose the jailbreak.

Please confirm if doing a software update in general will uninstall the jailbreak

Me too. I can’t even do a restore. I even Tried doing so from my Mac and pc using iTunes no luck.

Same thing happened to me, my solution was to PAY for the the aTV Flash lifetime membership.
Altough i did pay 2-3 years ago the atv flash i had was no longer supported!!
Here is what i did
Run firecore, this updated my Apple tv to 5.3 (had 5.1)
Run ATV flash

Note: You will lose plex app. And XBMC is now KODI but looks the same, you need to back up your XBMC lib
and rom if you don’t want to loose them.
I just hope this lifetime membership money sucker deal is good for something in the near future.

Developers, Fix the bug finally!

It would be nice to know if they are working on a fix, or a new version that allows plex on 5.3.

Why the silence?

Note that I his is a Plex issue - not a FireCore issue. Therefore if you want it fixed you need to chase the Plex developers.

I stand corrected on the plex issue … But I would still like to know what’s happening to fix the bug without having to upgrade to 5.3

I fix it by flashing it from 5.0.1 to 5.3 with SeasOnpass and then installing Kodi with another program

Note: it worked better with previous XBMC, it seems Kodi is heavier for the processor and sometimes the video have some glitches

We’ve pushed a Maintenance update that fixes the missing menu on older Apple TV versions.

In a nutshell, some of the iOS 7 additions we’ve been working on were causing issues for versions older than 5.3. Everything should be back to normal now.

If your Maintenance menu is currently missing, simply run the aTV Flash (black) installer from a Mac or PC and it will install the new update.

Thanks for your patience!

Now Maintenance app is back. Everything works again. Thanks a lot!

In other words, if you bought the ATV Flash in 2011-2012 from firecore for $29.99, and you currently are running 5.0.1 on your ATV you should not update the maintenance app.

If you do or have done this, and can’t find your maintenance icon, you are left with the option to pay another $29.99 to firecore for a lifetime membership, then upgrade to 5.3 (and change XBMC for KODI + loose PLEX!!)

The old ATV flash will you paid $29.99 for, will no longer work for you.

Please correct me if im wrong, but this is what i had to do.

To pay for 2.5 - yes
To update to 5.3 - no.
You can just install it over. I’ve done. Everything is back. (apple tv 2, 5.0.2)

I got an error message when i tried to run the old ATV flash, saying it was no longer supported. (bought it in 2011)

You need the new one
2.5

And to get the new one(2.5) you have to pay.
I lost the maintenance icon after updating before the fix , so i had to pay to get the new.

You are right. I did the same. If it works now?

Running 4.4.4 with Plex and Kodi and Infuse. Updated from Maintenance and lost Maintenance.
don’t want to start over from scratch and lose Plex.