Micro USB Does not Power ATV2

I have vast experience JB’ing every other Apple device so I thought I would try the ATV. After reading, the 2nd Gen seemed the best option at the  moment, so I bought a used one off eBay. Following JBing instructions and it says to not connect the power cord when attempting to JB. However, the ATV does not appear to get enough power from the Micro USB cable to allow windows to recognize it. If I connect the power cord and connect the microUSB, windows and iTunes have no problem with it. I have tried literally 7 different Micro USB cables, 2 of which I bought brand new (one from BestBuy and the other from Target). I have also tried connecting the ATV and Micro USB to 2 different computers and every USB port on both computers and it will still not power the ATV2 to perform the JB. I have tried on 1 computer running Win7 64bit and another running Win 8 64bit. Can try on a windows xp 32bit unit if recommended. Since there is no way to JB it with the power cord connected and there appears to be no way to get power from micro USB, I am dumb founded.

 

Any advice/recommendations are appreciated.

 

Thanks

I have 3 ATVs and 2 of them I have had problems Jailbreaking with just the USB providing power; the 3rd one jailbreaks just fine using USB.

I have tried the trick of starting with the normal power cable attached and then removing it but that didn’t work for me. This has worked for a number of people according to reports on this forum … But not for me.

What I found that works for me is to just leave the USB and power cables attached and when it does the restore with the jailbroken firmware notice that Windows detects the ATV USB device multiple times during the restore process. However the final stage (the verify stage) cannot be performed as it cannot put the ATV into the correct mode because there is a power cable attached and returns a 160x error at this point; however the jailbreak has been successfully applied so if I now plug it into my TV it comes up jailbroken.

When I do this I always plug in the USB and then the power … Not sure if this order is important or not.

If you get a 160x error at an earlier stage in the restore process then it indicates that something has gone wrong during the install process and you haven’t reached the verify phase … Usually indicated by the fact that Windows hasn’t detected the ATV as a USB device multiple times during the restore process.

I have encountered the same issue.  Strange though, with earlier firmware I didn’t get a 160x error, however, with 5.02 I have seen this.  And it seems that if I move the AppleTV (unplug the device, move it to another room, and plug it back in) I get the black screen with the Apple logo, and have to JB it again, kind of a pain.  Almost like it’s a tethered JB.  Have you experienced this at all?

I had the exact same problem yesterday. Could only force the ATV into dfu mode and then when unplugging the power, iTunes lost the connection.

I almost gave up until I decided to try another micro USB cable. This worked like a charm and iTunes found the ATV right away. No need for the power.

 

It seems like some micro USB cables simply can’t handle the current needed for the ATV.

 

I have the same issue. I have ATV3 trying to downgrade the firmware to 5.0.2 but its not working.

my ATV 3 doesnt show up in iTunes.

Just trying to find if anybody has similar issue and a solution for the issue.

Please advise.

Have you tried forcing the ATV into DFU mode?

  • Open iTunes
  • plug in the ATV Using USB and power
  • of not found then Press and hold the “Down” and “menu” buttons at the same time. Hold until the led on the ATV flickers really fast and then let go.
  • then Press and hold both menu and play until led flickers fast again. Then let go
  • iTunes should now show the ATV restore page
  • unplug the power, leave in the USB

Did that work? If not, then your micro USB cable doesn’t allow enough current (no charging).

My ATV lost the connection when i removed the power. I then tried the original cable from my old HTC phone. This worked.

Could it be the usb port itself?

I know we have problems at work if we use usb extenders (cat5) on some usb ports. This is caused by ports being hubbed. 

Of the six ports on the back only two are working 100% with extenders.

All you have to do is insert the power cord for a few seconds and take it out. This “Jump Start” of the ATV from the power cord will give it enough power to start the jailbreak process. Don’t leave it in, only long enough to keep the light flashing fast. This will be 2-3 seconds.

I have used this trick many times because I have a finicky ATV as well and a friend too.

This will work.

Good Luck.

Clutch

I have also used a Micro USB ‘Y’ cable of the sort typically used with 2.5" disk drives such as this with some success.

The Y-cable draws power from 2 usb ports and will work.

This is also the reason it is used on many usb hard disk drives / dvd drives.

 

Hi,

 

I tried what you suggested. Like inserting and removing the power cord. But as soon as I remove the power cord it is not showing up in iTunes.

Any other suggestions. I have used 4 different micro USB cables.

 

Thanks,

mandava.

 

Hi, either get an Y-cable. This will work on all usb ports.

Or find the usb port that is not hubbed.

The problem is that the usb port you use does not provide enough power for the ATV.

Well if it’s not getting recognized in iTunes at all once you jump start it then you probably do need more power coming through your usb hub. My hub is powered and when I get a finicky ATV that won’t blink from the hub power the jump start trick works good. It you can get a little more power through your cable you should be fine. My hub is just a standard powered usb hub I bought at Staples years ago.

Good Luck!!

Clutch

I ordered the y cable off amazon…once received I will post results.

Received “Y” Cable today…still does not work. ATV2 will not power up even with the two USB cords connected to two USB ports on the computer. Tried on a laptop and on a desktop. Also tried on a powered USB hub as well, with no success. Only thing I can think of is maybe there were multiple versions of ATV2 that have different power requirements and the one I have must have 100-240V / 50-60hz and USB ports just cannot deliver. Have spent hours researching every post on every forum related to this and it will not work. I think the end solution is to resell it on eBay and then try to buy one that is already jailbroken, probably the only sure way to ensure you have one that can be jailbroken. 

Probably doesn’t help now, but if you have another hub or a different USB ports, especially try from the back (front USB ports of PC cases are often actually a really cheap USB hub).

I’ve used PC’s that didn’t provide enough power from the front ports for other devices, or worse, were USB 1 instead of USB 2.

The first time I jailbroke my AppleTV, I also had 2 cables that didn’t work with it.  

  • First one didn't provide power (same as you're complaining about), 
  • 2nd cable gave power but I kept getting errors 
  • and the 3rd cable (a thicker logitech cable that came with a harmony remote) finally worked

I also can’t jailbreak from my old laptop running WinXP for some reason.  Never figured that one out.

** Just going to add - my friend discovered that his appletv had a poor connection inside in the port on the appletv.  He said he polished the contacts, but I’m not sure how he did this.

ive tried 3 or four different Micro USB cables until I found the one that works perfect for me.

 

Turns out its a 6" cable that came with my old Blackberry for charging, in fact it didnt even charge my blackberry, but works with any ATV2 that I throw at it.

 

ATV2’s are temperamental little buggers.

I have 3 ATV2s. The first 2 (purchased previous to 5.0) jailbreak just fine – the third one (purchased with 5.0) is giving me this issue… the micro-USB alone does not power the unit. Is this device somehow different than the other 2? Jumpstarting with the power cable doesn’t work at all. I’ve ordered the Y Cable but from the previous comments I am not hopeful.

 

Indeed, this is an old post. Has anyone discovered a solution for this since? Thanks.

I have found that with the latest SeasonPass the jailbreak seems to proceed fine if you have both the power and micro USB plugged in.

 

Wow, I’m an idiot. Just realized this 3rd device is an ATV3. I had no idea. My bad!