Metadata, still different from devices

Hell guys,

So, first, like allways, Infuse, best movie player ever !

Then…

I still have some issues, about metadata, like, I get a lot of different “hits” while using ATV A and ATV B…

Yes, I can correct them on ATV A, but it’s like ATV B never get this info, even though I use iCloud and so on.

It’s the same if I take one of the kids iPads. and connect to my library, then a lot (like 40-50% of the movies on the share is wrong metadata)

Do we “still” need to set up the metadata, for every devices, even though it’s the same network share (local) ??

thx

Are all devices logged into the same user id for icloud? Not just set up for multiple users under family share?

Same yes :confused:

Are you using Infuse Pro?

Do you have iCloud Drive enabled on each device (more info on the requirements for iCloud Sync can be found here: https://support.firecore.com/hc/en-us/articles/115000070773-iCloud-Trakt-Syncing)

Did you shares sync over to other devices automatically, or did you set up the shares on each device separately?

I use Infuse Pro and I’ve always wondered whether or not the metadata database is shared among my devices (Apple TVs, iPhone). They all are on the same Apple ID and I have iCloud syncing on. I’ve been having trouble of late with gargantuan metadata databases (>20GB) so I’ve been trying to pare down the Plex shares that they use. If they all use the same database, then I’d like to get a stable file that is consistent among all of the clients. How does the metadata database work anyway?

1 Like

If you’re streaming from Plex, Infuse will use PMS as the central database server instead of fetching metadata from TMDb/TheTVDb directly.

You will still have a metadata cache on each device, but this will reflect the data stored on your Plex server and should be consistent between all devices.

That makes sense. Now I have to determine why that two of my Apple TVs have reasonably sized metadata caches (1 GB) while the third one makes a cache that’s 22 GB(!), which is slow and unmanageable.

In the case of not using Plex, I have the same question as Sevenfeet: “I’ve always wondered whether or not the metadata database is shared among my devices (Apple TVs, iPhone). They all are on the same Apple ID and I have iCloud syncing on.”

For example, if I’ve cleaned and customised my database on one device, if I then connect Infuse on a new second device, with the same Apple ID and iCloud sync enabled, does it reuse my customised database… or do I start from scratch again on the second device?

Then, to go further, is it possible to share my customised database with other Apple IDs (i.e. if people were using the same media files/collection but had different Apple IDs)?

I had an ATV that was bloated when the others were considerably less and all I could figure out is that the bloated one had remnants of older scans that didn’t get cleaned out. This was about the time that Infuse switched over to iCloud for metadata. The easiest way to correct it is on the bloated ATV, select the “Clear Metadata” and let it rebuild the database. The textual part will be pretty fast since it’s coming from iCloud and the artwork usually goes pretty quick… Mine was the same as the others after I did that and they’ve stayed the same since.

I have been using the “Clear Metadata” feature and this one ATV still comes up with a bloated database. I’ve figured out from the other ATVs that I cannot just have an SMB server in the library path with all kinds of extraneous stuff that might end up in the cache, so I’ve pared that down. But I thought I did it on the ATV that has this problem only to have it generate a 22GB metadata file again. I’ll have to try again.

Make sure that all ATVs are signed in under the same user id for icloud. Also make sure that iCloud sync is turned on in every ATVs settings.

Maybe just me, but could be nice if:

You where able to choose one “master” iPad, ATV or what ever, and the metadata you made on this device, was the metadata all the other devices took.

Yes, if it’s local it make no sense, but if it was on a local network share

One thing to check is that you are connecting to Plex via the same method on all devices.

  1. Using ‘Connect to Plex’ will allow Infuse to fetch metadata from the Plex server.
  2. Selecting the Plex share from the list of Available Shares will connect to Plex via DLNA, and Infuse will fetch its own metadata.

You should be able to see which connecting type you are using by tapping the saved share name, and selecting the ‘Edit’ option.

The Infuse meta data cache differs on all my devices.

  1. iPhone 500 MB
  2. Apple TV 4K (64GB) 1 GB
  3. Apple TV 4k (64GB) 560 MB

Infuse is configured identically on all devices and the two Apple TV 4Ks have identical settings. All three devices are configured to connect to via SMB share to the same library shares. Shouldn’t the cache be similar on all devices, especially the two Apple TVs?

At the moment images are not synced via iCloud and are downloaded from the internet as required so that can explain them being different.

Have you tried clearing metadata on each and letting them all refresh? That’s what I had to do to get all 4 ATVs showing the same levels. They’ve stayed that way since.

My shares were indeed proper Plex shares and not DLNA.

But I think there was something going on with Infuse on this specific Apple TV 4K. I’m thinking that every time I asked to delete the 22GB metadata database that the database never actually got deleted, hence it always came back with that same 22GB file.

So the only option was to delete Infuse and start over. I’ve added the shares and it’s rebuilding the database now but I hoping this time it will be better.

Yes, I deleted the metadata caches inside Infuse on both Apple TVs and let them rebuild. Did that this morning before posting and one Apple TV 4K is showing a 1GB cache while the other is around 500MB. Identical SMB shares and libraries on both … same as my iPhone.

Just a side note, you shouldn’t have to add shares back when you reinstall Infuse. If you’re using iCloud sync it will reload all of that from the icloud account. It takes a few minutes but it works. I got impatient and found out if instead of doing the add shares when you launch a clean install, you can go to settings and then select library and you’ll be able to watch the icloud sync with shares and then the library rebuild.

I’ll have to remember that next time. I ended up doing everything from scratch which wasn’t that hard to do. The new metadata database is also about 1GB which matches the other Apple TVs which has good quick UI feedback. So I think my problem is solved. I’m not sure what bloated the database in the first place but I think it may have to do with having an SMB mount point that had a lot of stuff not meant for Infuse to index.