Metadata problem with one season of TV show

Greetings.

Sorry for bumping the topic, but I’m curious, why Infuse Pro easily recognizes all series’ seasons but one despite same naming policy? I have “Scrubs” series, sorted by folders, sorted by names like this:

  • Scrubs/Season 1/Scrubs 1x01 My First Day.avi
  • Scrubs/Season 1/Scrubs 1x02 My Mentor.avi
  • <…>
  • Scrubs/Season 1/Scrubs 1x24 My Last Day.avi
  • Scrubs/Season 2/Scrubs 2x01 My Overkill.avi

and so on, but only season 3 wouldn’t be recognized neither automatically nor manually. Series naming made in English, I tried both English an Russian scrapers with same zero result. If I do rename files to S03E0X, scraper react instantly, but main question is why with 3x01 it’s fine with everything but season 3? :slight_smile:
Thank you in advance.

Welcome to the forum!

Can you provide an example of exactly how you have one of the season 3 episodes named?

To add to that sometimes a screenshot of the files is more helpful as sometimes a typo gets overlooked.

1 Like

bingo :+1:t2:

These are the files for S03, which has not been indexed as intended:

Is it possible that the “x” in the season/episode number is not an actual letter “x”, but a character that looks like one (maybe a multiply symbol)?

What happens if you change the “3x01” to “S03E01” ?

Seems the “x” works on seasons one and two but not three. Would need to see a screen print of either season one or two to compare with season three.

It is possible, but it’s not the case - I checked. Renaming to SXXEYY does the trick, but as I said question is about why either working or not.

@NC_Bullseye
Sure, and another thing to mention: manual input doesn’t show “Scrubs” series from 2001 in search results at all

I just tried this here, and was able to get season 1, 2, and, 3 recognized without issue.

What type of device are you streaming from? Are you using UPnP or DLNA by chance?

Can you try using the ‘Edit’ option on one of the episodes from season 3 to see the actual filename Infuse is seeing?

Could you check to see if season 3 episodes are in a season 3 folder or are they loose in the series folder?

I’d highly recommend to follow the S0XE0X structure. I’ve found that of the naming options available this format will cause the least amount of problems. I went back and renamed all of my series to this and have had little to no issues.

I’ve posted a pic of this file structure here

@james, no it’s stream from a Synology NAS via SMB, no UPnP/DLNA/etc
Name Infuse is seeing is one I see in Windows Explorer, but I have news, please, see below.

@NC_Bullseye, all episodes were inside their folder, yes, and totally agree on S0XE0X, but seeding a torrent you are not at liberty to modify it’s contents in any way.
Nevertheless, I did manage to fix my situation up, manually replacing “x” with “x”, like remotevisitor advised (sorry, cannot mention more than 2 persons at this moment), and it worked, which in fact was weird since automated regexp replacement haven’t yield any results.

Anyhow, problem solved, I can only thank everyone for their time and apologize for the time wasted, I should’ve think of testing file names myself.

2 Likes