Metadata not finding a TV Show listed in thetvdb

I have a folder structure in Google Drive that has the tv show documentary series “WWII in HD” WWII in HD -

I have named the files as they should be named according to the Infuse documentation.

In Infuse on iOS it doesn’t pull the metadata from the correct show, instead it’s trying to pull from WWII in HD: The Air War" and when I try to search for WWII in HD, it doesn’t exist in the search, even though it’s in thetvdb.

What’s going on?

1 Like

Oh man—give up now. I’ve tried every possible naming of that show and it simply won’t match. I just mentioned this exact show’s problem last week: Metadata differences between tvOS and iOS versions - #7 by danemacmillan

I even went as far as acquiring that damned Air War one and that 3D one, which you’ve inevitably seen suggested as well, just because.

What a BEAR! Figured it out.

File name for the series “World War II In HD S01E01.ext” The “WW II” didn’t work for some reason.

Don’t forget to change the series folder name to “World War II In HD” also.

Just tested it and it picked up the right info first time, didn’t even need to try to edit.

If that really does it, you will have helped me in achieving a 100% library match on a fresh run. I literally have ten things in “Other,” and they are ten episodes of this damned show. It’s been a long trek.

I’ll report back.

Doesn’t seem to work. The file picks up “WWII in 3D” metadata, and when I do edit metadata, it finds “World War II in HD” metadata but it’s wrong, and doesn’t seem to pull any useful data from thetvdb. TheTVDB lists the show as “WWII in HD” so I don’t understand why Infuse can’t find it when you manually search for it.

It will work if you move the files out of the directory that Infuse scans for metadata and let Infuse complete a metadata scan without it. Then after you rename the files and folder to what I posted and return them to the directory it will pick them up on the next scan.

For some reason once infuse finds what it thinks is a match it will keep it even though you change the name sometimes.

I verified twice last night that with the names I provided for the files and folder it will grab the correct metadata.

Here is what I got with the file names and folder name I provided all without having to edit and what the edit screen looks like even though I didn’t need to use it.

It’s not working for me. I named them exactly as you said, and I moved the files out, resynced library and even cleared metadata. Moved the folder back in, resynced metadata, and now it’s showing me a Russian movie from 1941 about WW2 at the poster, with no groupings. I think the problem is Infuse for some reason thinks it’s a movie, not a TV show, even though I’m using the S01E01 nomenclature that it expects.

I wonder if somehow Google Drive is causing issues with the rename.

I wonder if you created a new folder in google drive and inside that created a new folder with the new name for the series and then uploaded a couple of new video files with the new name. Don’t just move the old ones over, upload a couple of new ones to test.

As you can see from my screen shots that it picked up the correct metadata without a hitch

Also, I did not include the episode name so I’m not sure if Google is causing that to be misinterpreted.

Not sure what you have for upload speeds but if you have a fairly fast connection I’d delete the whole series, folders and all, then change the name on your local computer to what I have and then re upload them to google drive.

Well, as a follow up, I created a Google Drive and copied the series (folder and episodes) that worked on a local NAS and it doesn’t work from google drive. I copied them back to a local drive from google drive and Infuse again found the correct metadata all by itself.

Google drive is causing some issue and I’m not savvy enough to know what. I guess we need a google drive guru.

This seems like an interesting quirk, and something we may need to look into.

For now, I was able to get the right info by naming them as “Word War II S01E01.ext”, and using the Edit option to manually search for the correct title.

See attached.

Was that from files on google drive ?

Yep. :slight_smile:

Well now I’m REALLY puzzled. I tried to do an edit and it would not see it as a tv show. No matter what I put in the search field the only suggestions were all movies.

Well that is bizarre, I renamed the google drive files to “World War II S01E01.EXT” (Deleting the “In HD” from my original file and folder names) and like James was able then to edit and it offered the WWII In HD series. Selected that and it loaded the correct metadata.

There is strangeness though when you use the naming I provided originally with a file on a local NAS and you don’t even have to edit, it just finds it and loads the correct metadata. Google drive is causing something to be looked at differently.

One additional note, even after the episodes grabbing the correct metadata the series folder doesn’t grab the series artwork or the correct series name.

Like OP, nothing has worked for me. This show defies metadata.

Odd that removing “In HD” from the title would suddenly reveal more options. Infuse is usually very persnickety about naming. Given that you made it return more results, dropping the “In HD” probably stems from inside knowledge of how matching works. The words themselves are good “unimportant” words that don’t usually contribute to matches, similar to how Google will drop “and” from searches.

I did as suggested, renaming to “Word War II S01E01.ext” and upon the first pass, Infuse auto-matches with some other title. Editing the metadata then brings up the suggestions that include “WWII in HD,” which is the correct match, but of course the naming differences for this are confusing.

I know of a couple of other titles that also refuse to auto-match, unless editing metadata and typing the title, despite the title of the file being identical; I would expect Infuse to just match if it’s the only one that comes up, but it doesn’t. In these cases not a single word needs to be dropped for the search to bring up a match, but Infuse will nevertheless refuse to match on its own.


I’m testing to see if “WWII in HD” will match (note the non-capitalized “in”).

(By the way, the speed improvements to indexing from a few releases ago finally make this kind of testing feasible. It takes just a few minutes vs over an hour to update indexes. It’s the best update to Infuse in 2018 for me.)

Are your files also on Google drive?

They are.

Do you have a local server that you could try using the filenames and folders I found to work? Something is strange with google drive and this series.

Infuse 6 update hasn’t solved this issue. Even though TVDB lists the show as WWII in HD, and that is how I have named my copy, it still can’t find that show’s metadata for whatever reason. When you try to edit metadata, it literally cannot find WWII in HD.

Here’s the weird thing: If I change the individual files from WWII in HD S01E01 to WWII S01E01 then I am able to edit the metadata and select the WWII in HD metadata. Weird right? Now it works perfectly after I selected the metadata.