Metadata mismatch difficuilty

For most title/files the auto metadata works very well - except stumbling every time on missing " ’ ", " : " and similar special characters that are often purposely omitted from file names.

However, I have one specific problem involving two files and trying to associate the correct meta title:
“10.iso” - (https://www.themoviedb.org/movie/9051)
and
“10x10.iso” (https://www.themoviedb.org/movie/505177)

When first auto-scanned, file 10.iso was given 10x10 metadata and 10x10.iso file given Kidd Video S10 E10 metadata.
Corrected 10.iso to 10 metadata, no problem.
But I cannot correct the 10x10.iso file’s metadata. “10x10” will not appear in the search results, no matter how I try, and, unlike all other files, the “-none use local metadata-” option, usually at the top of the search result is also missing. So I can’t even just disassociate it.

Anyone had similar or any suggestions.

Thanks.

This works
“10 1979.mkv”
“10 by 10 2018.mkv”

I used mkv but iso should work.

Thanks for trying. Already no problem with “10”

But “10x10” still no joy. Trying “10 by 10” was a great idea though.
Really odd, considering 10x10 metadata was mistakenly assigned to 10.iso automatically but, now, cannot get it to appear in a search result - screenshot attached.
Additionally odd that it seems to also not have the “- None - use embedded metadata -” option.

If you change the file name to 10 by 10 2018 it will work.

These file names pulled the correct metadata without having to do an edit.

10_and_10_by_10_files.png

Thanks again NC.

Yes, you’re correct. If I rename the file to “10 by 10 2018.iso”, it pulls the correct metadata. But, unfortunately, I can’t keep this filename and need to change it back to “10X10.iso”. It then, in turn, reverts the to the incorrect metadata.
Needing to rename the file is clunky, to say the least.

Is this a problem with Infuse or TheMovieDatabase or both?..

As it says in the Infuse users guide, release year is not required, but it can be used for better results and this is one of those times.

You can also use the file name “10 x 10 2018.iso” and that too will work. If you have to leave the year out try 10 x 10 with a space on both sides of the x and then do an edit metadata, that may work but I haven’t tried it.

Edit to add:I just tried the 10 x 10 with a space on both sides of the x (10 x 10.iso)and and it worked without having to do an edit.

Understood and all makes sense in regard to the automatic allocation of metadata.

  • Please humour me and assume I can’t permanently rename any files.

My issue is with the manual allocation of metadata. I’m perplexed why I cannot find and allocate the 10x10 metadata when I search for it. This is compounded by the additional strangeness that I cannot even remove the wrongly associated metadata title.

It appears that themoviedb has it with spaces between the 10’s and x for the API used to search. If you can at least change the name to have the spaces then it’s good. If not you may have to add your own artwork and xml file.

I appreciate the help but, unfortunately, we’re starting to go in circles.
Renaming the file permanently is not an option. Hence, I need to be able to find and allocate the correct metadata title via the search function.

In this particular case, “10x10” is one of the naming styles used by TV shows (https://support.firecore.com/hc/en-us/articles/215090947-Metadata-101), so as a result Infuse is treating it as a TV series and not a film.

Unfortunately, the only way to resolve this it rename the file itself.

Thanks for the help James.
Aaah… I didn’t know that was a style of episodic TV shows… and thanks for the info link.

The only thing that still perplexes me, while understandably automatic metadata allocation won’t match, why I can’t just simply use the search option and override, no matter what filename…?
Admittedly, I’m bias as some other media players allow you to do this simple override.

Infuse uses the filename to determine which database to search. This is in contrast to other media players, many of which require you to tag certain folders as movies, and other folders as TV shows manually. With Infuse, you can just have one big pile and it will sort out everything for you.

This works pretty well in almost all cases, though admittedly in rare cases like this there can be a few manual filename tweaks required.

1 Like

Ok, finally the light bulb moment for me! Since it’s using different (TV vs. Movie) databases, hence I can’t find it when searching manually.
That’s the bit my tiny brain was missing. Still a shame but I understand now.
Thanks very much James!

Sorry, just one more question on this - then I’ll shut up :slight_smile:
Thanks to your explanation, I understand the file naming, different databases, etc… but, I’m still wondering why, just for this particular file, I don’t have the “None - use embedded metadata” option, normally available top in the search results?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.