Metadata grabbing not working

Hello

since a few days (don’t know since which version) the Metadata Grabber is not working fine.

For example:
The Equalizer.mkv in the folder: The.Equalizer.2014. (and so on)
The Equalizer 2.mkv in the folder: The.Equalizer.2.2018. (and so on)

are both set to The Equalizer 2

Hangover.mkv in the folder Hangover.2009. (and so on)
Hangover 2.mkv in the folder Hangover.2.2011. (and so on)
Hangover 3.mkv in the folder Hangover.3.2013. (and so on)

are all set to Hangover

Pan.mkv in the folder Pan.2015. (and so on)

is set to Peter Pan from 19XX

Der Unsichtbare.mkv in the folder Der.Unsichtbare.2020. (and so on)
is set to Der Unsichtbare dritte from 1959

So that’s a bit messy

Try naming the files with the year in them.

The Equalizer 2014.mkv

The Equalizer 2 2018.mkv and see if that clears it up.

Putting the year in the file name like this will solve a majority of mis matched metadata.

Actually, folder names means nothing, the app will grab metadata from the file itself, so, if u name the files with the year it will help, as told by @NC_Bullseye.
As a matter of fact, u can “manage” the metadata by clicking on “Edit” and choosing yourself the matching content but, I guees this would be such a headache if u have lots of movies.

Well, the problem can be solved if Infuse adds an extra match exact algorithm matching title.

https://community.firecore.com/t/improve-accuracy-really-important/31495

I’d suggested but seems no one care…

1 Like

Realy?

I have all three 96 Hours Movies in different folders (each movie in one folder)

Folder: 96.Hours.Extended.Cut.2008.German.AC3.DL.1080p.BluRay…
File: 96 Hours (2008).mkv

Folder: 96.Hours.Taken.2.Extended.Cut.2012.German.AC3.DL.1080p.BluRay…
File: 96 Hours Taken 2 (2012).mkv

Folder: 96.Hours.Taken.3.Extended.2015.German.AC3.DL.1080p.BluRay…
File: 96 Hours Taken 3 (2015).mkv

And this ist the result: :pensive:


:grimacing:
The grabbing actually is rubbish.

And why it shows me the folder name if I want to edit the metadata manually?

Could you try this?

The majority of users don’t place individual movies inside individual folders for each movie.

Folder: 96 Hours (2008) Extended.Cut.German.AC3.DL.1080p.BluRay…
File: 96 Hours (2008).mkv

Folder: 96 Hours Taken 2 (2012) Extended.Cut.German.AC3.DL.1080p.BluRay…
File: 96 Hours Taken 2 (2012).mkv

Folder: 96 Hours Taken 3 (2015).Extended.German.AC3.DL.1080p.BluRay…
File: 96 Hours Taken 3 (2015).mkv

Sorry, but the grabbing is still rubbish.

The Fast and the Furious.mkv and Infuse grabbed it as The Fast and the Furious: Tokyo Drift

Seriously? Why? There is no Tokyo or Drift in the filename

Fast and Furious 6.mkv is grabbed correctly to Fast & Furious 6
and than:
Fast and Furious 5.mkv
Fast and Furious 7.mkv
Fast and Furious 8.mkv
are ALL grabbed as Fast & Furious 10. :woozy_face:

All Fast and Furious files are in one folder (Fast and Furious Saga)

John Wick.mkv is grabbed as John Wick Kapitel 3 (why, there is not a single number in the filename)
John Wick Kapitel 2.mkv is grabbed as John Wick: Kapitel 2
John Wick Kapitel 3.mkv is grabbed as John Wick: Kapitel 5

Again, following the recommended naming of movie name and year will fix the vast majority of the issues you’re having.

Here are the names of the fast and furious collection and all will grab the correct metadata when used as a file name. Note that special characters like the ampersand (&) and colon ( : ) should be changed to the word “and” and just delete the colon since some systems see these as control characters.

These file names pulled all correctly without a problem first time.

The Fast and the Furious 2001.mkv
2 Fast 2 Furious 2003.mkv
The Fast and the Furious Tokyo Drift 2006.mkv
Fast & Furious 2009.mkv
Fast Five 2011.mkv
Fast and Furious 6 2013.mkv
Furious 7 2015.mkv
The Fate of the Furious 2017.mkv

You can add additional info after the year and before the extention and the API will still gather the correct info.

Please add the release year to your file names to help the API select the correct info.

That may be true, but the naming of

Fast and Furious 5.mkv
Fast and Furious 7.mkv
Fast and Furious 8.mkv

is 100% unmistakable. So why can’t Infuse work with this clear data?
I can’t and will not understand why Infuse cannot Name Fast and Furios 6.mkv with Fast & Furious 6

There is no second option

The selection of the movies is coming from TheMovieDB API, not Infuse. You can bring it up with them if you don’t like the order that gets returned. But you can manually select the correct movies within infuse or change the file names as NC_Bullseye suggested.

It may be clear to you but those are not the names of the movies. One could use the same argument that it should recognize “First Fast And Furious.mkv” “Second Fast And Furious.mkv” and so on but those are not the names of the movies and the API is not going to see them correctly.

If you name the files using the recommended format with the correct name of the movie things will work.

You can still put them in a group folder and that won’t affect a thing but If you want the correct metadata without hassle you’ll have to name the files correctly.

So, can you explain the problem here:

And this is the result:

I´m now over 1 year Infuse user. At my beginning with Infuse there wasn’t such a problem with the grabbing/naming

Yes, there is no number after the name, I don’t read german but it looks like you have “Pirates of the Caribbean 5 Dead Men Tell No Tales 2017”

It should be “Pirates of the Caribbean Dead Men Tell No Tales 2017”

Get rid of the extra numbers. If you really want to have the numbers put them after the year in the file name.

I´m now renaming the file to Pirates of the Caribbean - Fremde Gezeiten (2011).mkv
and this doesn’t work

Okay. I´m now 100% sure that the folder naming is important.

I´ve renamed the folder Fluch.der.Karibik.5.Salazars.Rache.2017.German.AC3.DL.1080p.BluRay.x265-HQX
to
Fluch der Karibik 5 (2017) Salazars.Rache.2017.German.AC3.DL.1080p.BluRay.x265-HQX

And now it works

If you look at TMDb site there is no number after Pirates of the Caribbean so that might throw it off sometimes. You can also do a search there to confirm.

And would work the first time if you would follow the naming format for both the file and the unnecessary folder you add.

Yes. I´m now renaming the files with the title from TMDB



And the problem is the same
All 3 named as Fluch der Karibik from 2003

I´m naming the files now with the title from TMDB
But this doesn’t work
Its only working if I change the folder name too

And once again, you do not need to place the movie in it’s own private folder, if you do this at least name the folder the same as the movie,

But why is this problem new?

I´m over one year with Infuse and this problem wasn’t there all the time.
In my beginning with infuse the grabbing works great